It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why can't I create a subtask from the view issue screen? Edited

I am using Jira Core hosted in the cloud. I have permission to create issues. When I click on an issue from my board, I have the option to create a sub-task by clicking the "Create subtask" button. When I click the "Create subtask" Button, a box appears that says "Subtasks" with the description "What needs to be done?". I am given two options: "Create" (which is greyed out) and "Cancel". If I type in the box, the "Create" box changes from being greyed out to blue. However, when I click on "Create" nothing happens and no subtask is created.

Cannot create subtask 2.JPGI have checked and both the Task and Sub-task issue types are allowed in the assigned issue type scheme. Issue type scheme.JPGAny and all help is appreciated.

2 answers

1 accepted

0 votes
Answer accepted

I was able to determine that it was indeed the Field Configuration that I was using for subtasks in this project. I had set a Checkboxes custom field "Department" as required for the subtask. Once I made "Department" optional, I was able to create a subtask. However, when creating the subtask, I want to be able to set certain fields such as Assignee, Due Date, and Department. The way it is currently, when the subtask is created it is automatically assigned to the Project Lead, and I am not given the option to set any custom fields without clicking on and viewing the subtask. Is there a way to set these values upon creation of the subtask? Maybe this should be another post.

0 votes

Are you getting any error in the log files or any java script error?

Have you tried using a different browser?

I apologize, I am relatively new to Jira. I checked the Audit Log under System Options, but did not see any errors listed there. Is this what you mean by checking the log files? I also do not know how to view the java script. Any direction you can give regarding that would be helpful as well. 

I have tried using two different browsers (Chrome and Edge) and both had the same result.

I was able to create subtasks in this project until yesterday. I recently created and assigned this project's Field Configuration Scheme, and I am wondering if I have somehow messed things up there. Is there any way this could affect the ability to create a subtask?

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you