Users can sometimes not link issues

We're observing this very odd issue where certain users can not, for a certain period of time, link issues. Symptoms seem to appear and disappear at random times.

At first, I thought we were seeing this https://answers.atlassian.com/questions/157332/can-t-link-issues-in-project-despite-having-permission - but really the error message is different, and the linked issues field is emptied. We get this message: "You must specify a JIRA issue to link to", which is the same as if you enter no issue indeed. And while inspecting the POST request that's sent when we try to confirm the "link" dialog, we indeed see that, for some reason, the issueLinkIDs parameter isn't passed in the POST request.

Unfortunately, we have no idea how to reproduce this at the moment. Logging out, clearing caches, logging back in, doesn't seem to help.

I don't believe it's a permission issues, since the same user is able to link "sometimes" (same issues being linked). We also tried with different browsers, and that's not it either (fails with both when it fails, works with both when it works).

Nothing seems to show up in the Jira logs when this happens.

We're using 5.2.5

We'll be happy to try anything you can think of to track this down ! Any clue ?

Cheers,

1 answer

Hi Gregory,

This is odd indeed, do you have anything in front of JIRA, such as a proxy or load balancer, that may be interfering with the POST request?

In case yes, you may try to attempt to replicate the issue accessing JIRA directly via localhost.

I hope it helps.

Cheers

We do have an Apache HTTPD in front, but really, it's just mod_proxy with ProxyPass and ProxyPassReverse. However, I'll try next time we bump into the issue, for completeness' sake.

Sooo,.. thanks for the suggestion! But... just had a user bump into the issue again, tried with bypassing Apache, and unfortunately it didn't help.

Hi Gregory, have you ever pinned this to a cause? We seem to have a similar issue and run JIRA 5.2.5 as well.

Hey Mariska - hmmm. Not really, or not that I can remember (I was hoping to have an issue about it in our own Jira, but I can't find that either) - sorry ! We haven't seen the issue since.

Ok thanks. Hopefully we will have the same experience as you!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Apr 17, 2018 in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

818 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you