Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,293,568
Community Members
 
Community Events
165
Community Groups

Is there a way to disable links transformation in JIRA?

Edited

In the past if someone pasted an URL to a comment section (or the issue description field) it would be displayed as an URL linking to the corresponding page - http://example.com

But recently Atlassian rolled out a change that makes "pretty links" - instead of showing the original URLs it gets the page title and displays it as the link to the page. So instead of http://example.com it would show something like Example Website. It's great that this "feature" hasn't been applied to this forum otherwise I wouldn't be able to explain it :-)

Same thing started to happen in Trello recently.

While this seems to look cool, I often need to copy the comments or descriptions from JIRA and paste them elsewhere, and with this change all links become just page titles.

Even if I edit the comment, there's no way to view its original text with full URLs, so there's no way to get the original URLs other than copy-pasting each of them separately which is of course not very good.

I would really like to be able to easily copy the original comment/description text with full URLs or even better - have this automatic conversion completely disabled everywhere in JIRA and Trello. How can I do this?

9 answers

> Unfortunately not at the moment, this is called "Smart Links" 

please, change this terrible functionality,

Smart Links is a HELL of jira user! I want to have possibility to disable Smart Links feature for my account in jira settings.

You're welcome to this thread: https://jira.atlassian.com/browse/JRACLOUD-72429

It's frustrating how JIRA team ignores hundreds of disappointed users.

Like seaghan moriarty likes this

Totally voted for that.... but it was first sent up in July 2019.

Faith this will be addressed = NULL

Unfortunately, at this point, there is no official way to do this. To get the effect you want, you would have to install a URL blocker (such as uBlock) into your browser and add the following URLs to the list:

https://YOURSUBDOMAIN.atlassian.net/gateway/api/object-resolver/check
https://YOURSUBDOMAIN.atlassian.net/gateway/api/object-resolver/providers
https://YOURSUBDOMAIN.atlassian.net/gateway/api/object-resolver/resolve/batch

Replace YOURSUBDOMAIN with the appropriate domain for your account.

This is an all-or-nothing approach, so all URLs in content will be rendered as linked URLs and no "Smart Links". Others have suggested this already, but it always gets lost in the comment stream.

Until Atlassian implements a settings option to control it, this is about the only way other than:

  • Ctrl-Z/Cmd-Z after pasting (for each link)
  • Ctrl-Shift-V to paste without formatting
  • Use a code block

Thank you for this work around.

@Andrew McDonald I wish there was a built-in option, but this is pretty universal behavior in Jira now. If you need the link reformatting, then you can disable the blocker temporarily. Note that with the blocker on, links that were previously reformatted will appear as normal links (but will retain the formatting attributes, should the page be viewed by someone else or with the blocker off.)

I cannot think of a single time where I thought, "Wow, I'm so glad that Jira changed the URL I just pasted."

Who thought this was an "enhancement" anyway?

I dunno, people at the UX front that have to justify their wages ?

Anyway, it has became pretty annoying lately to have everyone trying to embed a "preview" into the documents.

Twitter, Teams, Slack, Gitlab, etc do that as well, adding an annoying preview of the URL, but at least doesn't change it into something that could be obscure.

I'd say the URL transformation shall remain limited to Jira/Confluence links, but not otherwise as it is irrelevant.

And that should be disabled in the user settings. Not at admin level.

Isn't it funny how every time a company put "smart" in front of the function or product it is actually something idiotic that basically no one wanted or asked for ?  :) 

Thankfully it seems like they are finally listening https://jira.atlassian.com/browse/JRACLOUD-72429

1 vote

JIRA please implement a way to disable thank you

Here's what worked for me -- as soon as Jira transforms your link into a smart link press Ctrl + Z (or Cmd + Z on a Mac; I'm not sure what the undo action would be in Android/iOS) to undo the transformation and get your original URL back.

Apparently I can't delete answers.

You found out a solution for that link transformation thing ?

0 votes
Andy I'm New Here Jan 10, 2022

Not exactly a solution, but I tend to mark the link as code (ctrl-shift-M). That means, of course that it's then not clickable, but the advantage is that you can copy/paste the result into (e.g.) another ticket without it getting messed with.

0 votes
Olga Videc Community Leader Jun 18, 2021

Hello @Dmitry Beloglazov 

Unfortunately not at the moment, this is called "Smart Links" 

Here is a suggestion for the option to disable it

https://jira.atlassian.com/browse/JRACLOUD-72429 

Similar question lot of people share your problem

https://community.atlassian.com/t5/Jira-Software-questions/Is-there-a-way-to-disable-inline-links-Bug-report-SmartLinks/qaq-p/1673119

What you can do is when adding a comment, add URL as code block 

BR, Olga

Thanks.

> https://jira.atlassian.com/browse/JRACLOUD-72429 

Can't comment there for some reason, it shows a "Communications Breakdown" error.

> What you can do is when adding a comment, add URL as code block 

This doesn't work because I'm not the only one who posts the comment and I wouldn't prefer not to instruct everyone to add URLs in some awkward way.

Olga Videc Community Leader Jun 23, 2021

Hello, 

Can't comment there for some reason, it shows a "Communications Breakdown" error.

You just need to refresh the page, it happens if the comment box is open for too long.

BR, Olga

I reopened this page multiple times, same error.

Olga Videc Community Leader Jun 23, 2021

Have you added any URL or code in your comment?

No. But probably it doesn't matter much. I see a hundred of angry comments and I hope it's enough for Atlassian to do something about it :-)

Like Peter J Lennartsson likes this

Looks like I found a bug.

When I opened that URL, I was redirected to this URL: https://jira.atlassian.com/browse/JRACLOUD-72429%C2%A0?error=login_required&error_description=Login+required&state=65e12ff6-ebec-41dd-b428-528f3b81148b

And there I couldn't comment.

When I removed everything starting from %C2 and reopened the page I could submit the comment.

"Smart Links", you can call it all the names you want, it doesn't do what WE want.

Linking to Gitlab from Jira I get a "SAML SSO for EVBox" for every link I post.

Yeah, because it's behind an ID wall and Jira couldn't get past through it.

Just display the damn URL and voilà.

"Smart ass"

Like # people like this

@David KochUnfortunately they don't seem to care.

You can check this epic thread: https://jira.atlassian.com/browse/JRACLOUD-72429

Also you can vote for it.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you