Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Deactivate internal comments

Hi community,

in JIRA ServiceDesk you can choose, if you want to comment a ticket internal (only your staff can see the comment) or comment to the customer.

We dont need this feature, we want all comments to be visible for the customer. I know, this CAN be risky, but we had different cases, in which our support team member closed a ticket with a comment, but mistakenly clicked "internal comment". So the customer got a notification, that the ticket is closed, but not a comment, why this is so....

Furthermore, when a customer wrote a comment in a ticket, we can press on "reply". But this reply is internal everytime. this is really frustrating and i couldnt find an option to change this option or even deactivate internal comments.

Do you guys know anything about it?

Thanks for your help!

Cheers, Lars

3 answers

2 accepted

2 votes
Answer accepted
Olga Videc Community Leader Jul 04, 2019

Hello @Lars Blaschka 

I tested for two days and nothing this is the reality is not possible at the moment

https://jira.atlassian.com/browse/JSDSERVER-1928

The suggested solution, but requires coding

https://jira.atlassian.com/browse/JSDSERVER-1928

The first solution I provided enables you to make all the comments internal my disabling comment function.

I can't find the tab that hides "share with customer" and "comment internally"

You can un accept my solution sorry I couldn't help more :(

Apparently, this plug should enable you to make the default option for comments.

https://marketplace.atlassian.com/apps/1217337/doublecheck-for-jira-and-service-desk?hosting=server&tab=overview&_ga=2.73524884.724977931.1561970829-899529972.1531837689

Found this plugin here 

https://community.atlassian.com/t5/Jira-Service-Desk-questions/Default-Service-Desk-Comments-to-Internal/qaq-p/268822

BR, Olga

Hi @Olga Videc , 

thank you so much for ypur effort!!!!!! Really appreciate it!

But your suggested solutuon works for us. I deactivated the "service-desk-comment-field" and can now no longer choose between Internal comment or comment to customer. All the comments are seen by the customer right now. This is exactly what we wanted. So your answer was very helpful :-)

 

The only issue we still have is the "reply" button in the comments. When a customer creates a comment and we press on "reply", our answer is still only internal visible. Thats risky :-(

But our workraound will do for now. We just dont click on reply anymore :-D

 

Again, thank you very much for all your help!

Cheers

Lars

Olga Videc Community Leader Jul 04, 2019

Hello @Lars Blaschka 

Can you please send me a screenshot of this "replay" button, and screen where it is?

Blur all the sensitive data.

I don't have that in my system or I just didn't notice it.

Hi @Olga Videc ,

sure, here is a screenshot of the button.

You can find it when you open a ticket and scroll to the "activity"-screen. Under "Comments" you see the comments of customers and other agents who created a comment for this ticket.

In this case, i used a test-account (Lars Test) which simulates a customer, who created this comment in the customer portal.

When an agent would press this reply button, the comment would only be visible internally.

Thank you!

Larsimage.png

Olga Videc Community Leader Jul 05, 2019

Hello @Lars Blaschka 

Took some time but I found it.

The reason I haven't seen it before is that is it is a custom field achieved with  Threaded Comments for Jira plugin.

The thing to watch out for 

1) When composing a reply in JIRA service desk, you cannot choose to post publicly or privately (all replies are private, though they can be edited to change to public) 2) Despite these replies being private, emails are being sent to reporters, and watchers (as per the JIRA Service Desk notification scheme, but seemingly ignoring public/private & internal/external permission considerations) 3) Though replies can be edited to expose as public, the dialogue window does not seem to close correctly (despite applying the change)

Also, the plugin is unsupported at the moment.

If you wanna keep using it, I played with it a little and found a workaround:

Go to Setting -> Manage apps -> CRTL+F find Threaded Comments and disable the feature enabled for all projects, just enter all the projects except your service desk so that feature won't be available there anymore.

You can see here it's unsupported 

https://marketplace.atlassian.com/apps/1212145/threaded-comments-for-jira?hosting=server&tab=reviews

BR, Olga

Like Dave Liao likes this

Hi @Olga Videc ,

I am speechless.... You are awesome... I cannot thank you enough!

I really appreciate your effort. 

Everything works now as we need it!

Thank you!

Cheers, Lars

Like # people like this
Olga Videc Community Leader Jul 05, 2019

Hello Lars, 

Anytime, glad I could help, learned something new along the way.

BR, Olga

Like Dave Liao likes this
1 vote
Answer accepted
Olga Videc Community Leader Jun 27, 2019

Hello @Lars Blaschka 

This should help, an explanation from Atlassian team 

If you can edit internal comment tab, you can remove it to

https://community.atlassian.com/t5/Jira-Service-Desk-questions/How-to-change-default-tab-to-internal-comment/qaq-p/56715

1. Keyboard shortcut : 'G'+'G' + Start typing 'Screens' and hit Enter
2. Locate the appropriate screen ( Assign to 2nd Line) and click on the configure button under operations
3. You will see the Respond to Customer and Internal Comment Tabs, and Add Tab.
4. You may drag and drop the tabs as you like. Hence, drag the Internal Tab to be before the Respond to customer tab.

Edit internal tab.pngBR, Olga

Hi Olga,

thanks for your reply, but I´m not even close to find this area where I can change this option.

What is keyboard shortcut 'G+G'?

When I configure a screen there are no tabs with "respond to customer" or "Internal comment"...

Can you explain this a little bit more detailed? 

Thank you!

Lars

Olga Videc Community Leader Jun 27, 2019

Hello Lars,

Just press g two times fast or go to settings screens and find screen named respond to customer, there you can edit this screen, I’m  writing on my phone now, but I’ll do some more digging and get back to you.

BR, Olga

Like Lars Blaschka likes this
Olga Videc Community Leader Jun 28, 2019

Hello @Lars Blaschka 

Found it :D

If we reverse the process from this documentation. 

https://confluence.atlassian.com/jirakb/respond-to-customer-and-internal-comment-tabs-missing-from-comment-in-service-desk-777026999.html

So these are the steps 

  1. Log into JIRA as a System Administrator
  2. Click the Administration Cog and go to Add-Ons
  3. Select Manage add-ons from the left-hand menu.
  4. Locate your JIRA Service Desk Add-On and expand this item to see further details.
  5. Click the link that shows "X of Z modules enabled.
  6. Locate the service-desk-comment-field item in the expanded list, if this module is disabled, click the "Enable" button to enable it.

Tested works for me

BR, Olga

Like Lars Blaschka likes this

Hi @Olga Videc ,

thank you so much for your effort!

Unfortunatelly ServiceDesk is not listet in the "manage add-ons" menu.

As far as i know, ServiceDesk is an own instance, not an add-on. But when you say it worked for you maybe we run on different versions of JIRA?

Again, thank you very much for your help! I appreciate it.

Cheers, Lars

Hello @Lars Blaschka 

It’s not listed because of default view in manage apps which is user installed apps, you need to choose all apps, right to search is drop down menu.

Apps.png

 

I had the same problem, took me a few minutes to figure it out 

Use Crtl+L to run a search and write Service Desk it should be around the middle.

JSD.PNG

BR, Olga

 

Like Lars Blaschka likes this

Hey @Olga Videc 

you are awesome :-)

Thank you very much! I found the servicedesk in the add-on menu and could deactivate the service-desk-comment-field item. 

Our serviceDesk agents can now not longer decide if they want to comment to customer or internally! Thats exactly what I was looking for!

Where I am still struggling is the second part of my question above:

"Furthermore, when a customer wrote a comment in a ticket, we can press on "reply". But this reply is internal everytime. this is really frustrating and i couldnt find an option to change this option or even deactivate internal comments."

I just cant comprehend this feature. When I want to reply to a customer comment, why is it internal? Can you change this somehow? 

Again and again and again, thank you so much Olga!

Cheers 

Lars

Like Dave Liao likes this
Olga Videc Community Leader Jun 28, 2019

Hello @Lars Blaschka 

Glad I could help.

Second part.

Will can start from here

Have you checked your permission scheme, also by customers you mean external users or people who have software licenses but not agent license.

This is two possible reasons

If "customers" are your colleagues

Cause

This can be caused by two possibilities. Either:

  1. The Service Desk License is not Agent Based and therefore JIRA Service Desk is not presenting an Agent View
  2. The service-desk-comment-field module of the JIRA Service Desk Add-On is not enabled.

For general customers, people who have access to your Customer portal, also check that your customers don't have browse permissions.

To make sure they cannot make internal comments, look at the Add Comments permissions in your scheme. Only roles/users/groups related to agents and "Service Desk Customer - Portal Access" should be there.

Hi @Olga Videc 

I think its the other way around. 

With customers I mean external customers who have only access to the customer portal. 

They cannot make internal comments. 

The issue is on our side with our service desk agents. when they want to answer to a customer comment by clicking on "reply", the answer is always internal and cannot be seen by the customers. Thats maniac.... 

There must be an option, where you can set whether the reply is always internal or always public. I just cant find it...

Olga Videc Community Leader Jul 01, 2019

Hello @Lars Blaschka 

I'll create a new testing environment  today and test it all in depth, I'll report back with results

@Lars Blaschka I am unable to find `service-desk-comment-field` under the `Jira Service Desk` in the Managed Apps section to disable internal comments. I've been researching so much and can't figure it out.

I need to completely disable internal comments for my Jira Service Desk! I only want the ability to "reply publicly"

@Olga Videc 

Hello @jhuynh , 

I also struggled like you finding the configuration, but @Olga Videc explained it pretty clear. You have to go to settings, manage add-ons, and now heres the little trick. you have to chose "all apps" at the searching settings and then search for service desk. 

image.png

After that, you have to click on the link that shows "X of Z" modules enabled.

Locate the service-desk-comment-field item in the expanded list. Here you have the setting.

 

Hofe this helped.

Cheers, Lars

@Lars Blaschka Thanks for responding!

I did just that- however when expanding `Jira Service Desk` I don't see any options, it's blank. I expanded other Jira Service Desk apps but i don't see the module service-desk-comment-field


I'm Using Jira Cloud..


2020-12-08_09-06-45.png2020-12-08_09-08-38.png2020-12-08_09-09-32.png

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you