Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't link a Bitbucket repo to a Jira Cloud project

This is weird. I'm using the new Jira Cloud and already connected it to Bitbucket. But when I'm in a Jira project and click "add item" in the sidebar, the only option is to add a shortcut.

Expectation from what I read:

expectation.png

What I'm seeing:

Captura de Tela 2019-02-15 às 15.22.17.png

1 answer

1 accepted

0 votes
Answer accepted

Hi Luis,

Thank you for reaching out to Atlassian Community!
I've tested on a next-gen and classic project and when Bitbucket is connected, it shows the options to add Shortcut and Repository.

Screenshot 2019-02-21_11-31-59.png

When you click on "Add item" does it show directly the option to add a shortcut?
Can you please confirm if Bitbucket is showing on the "Switch to..." and if it shows on Application Navigator?

Screenshot 2019-02-21_11-27-53.png

If it's showing but still not working, please disconnect and connect Bitbucket again following the steps of the documentation below:
- Connect Bitbucket Cloud to Jira Software Cloud

If you face any issue, please let us know.

Regards,
Angélica

Hi Angélica,

"When you click on "Add item" does it show directly the option to add a shortcut?"

- Yes, it goes directly to add a shortcut option.

"Can you please confirm if Bitbucket is showing on the "Switch to..." and if it shows on Application Navigator?"

- Yes, Bitbucket is showing up there.

alternate.png

Is it possible this is because the Bitbucket owner is not the same from Jira?

I mean, I created our Jira instance with my e-mail/account, but Bitbucket was created by other member of our company, who then added me as a team member (administrators group) there.

Hi Luis,

Can you please test using another browser and incognito window?
Also, can you please ask if another administrator is facing the same issue?
It could be also a translation issue, but I've tested in English and Portuguese and it works, you can try to change the language to English to check if something will change.

Regards,
Angélica

Hi again Angélica!

I tested it in Chrome and Safari, both in "normal" or incognito mode. I also tried it while logged as another administrator.

The results were the same: only the option to add a shortcut appeared. 

Can you please check on Jira Settings > Products > DVCS accounts if it shows the list of the repositories?
Also, is there any other project where you can test if it shows the repository option? If not, can you create a test project and click on "Add item" to check?

Regards,
Angélica

Angélica, finally we got something!

I created a new project using the Kanban template and the option to link repositories appeared.

The project I was trying to link was created with a Business template.

So, this only work with projects of the Software type. I didn't find this information anywhere while searching the documentation.

Hi Luis,

The ability to link Bitbucket to a project is only available for Jira SW for now, the documentation I sent on my previous comment was specific for an SW project. In the near future, it will be possible to link to an SD project, but not for a Business template.

Regards,
Angélica

We are currently using Jira Software Cloud.

In all honesty, I don't know what SW or SD means. I don't see this acronym anywhere in Atlassian docs. Also, there's no mention in the docs to this ability being unavailable to Business templates.

In my opinion, it should've been mentioned from the start. Something like "Bitbucket connection to Jira doesn't work with Business template projects."

Thanks!

I've created this other topic https://community.atlassian.com/t5/Jira-questions/Can-t-link-BitBucket-projects-to-my-Jira-board/qaq-p/1578470#M461519 as the answer in here isn't really solving the problem.

I followed all the steps and logically it should work, but it isn't.

We need a classic dev board, creating other type isn't going to work for us.

I can access other boards and I've lost the ability to connect repos altogether. I presume something has broken the feature.

We need help ASAP!

Thank you.

Solved!

I had to go to User Management and add myself to administrator group.

 

Screenshot 2021-01-13 at 13.39.08.png

 

I managed board as a site admin, for some reason I've lost access. Before adding myself to the administrators group I was tagged as site admin, so I'm not sure what the difference is, but I can now see this...

Screenshot 2021-01-13 at 13.40.33.png

 

Hope it helps others!

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you