Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,368,777
Community Members
 
Community Events
168
Community Groups

Share filter not available to specific group

Edited

I am working  on creating some filters that I would like to share. I definitely have the ability to share as I've added certain groups. However I have one group that I cannot add to the share.

 

I'm assuming this is some issue with permissions for the group but I'm not quite sure what they're missing.  I gave them Browse Projects permission but no others as I want to keep it as limited as possible.  Is there some other project level permission the group needs.

 

I want to add bfi-dallas group.

This is what shows in the filter listcurrent groups.PNGHere is when I edit the filter.Permissions dropdown.PNGHere is the one permission bfi-dallas has.permissions.PNG

When I try to add I get a no group found message.

2 answers

1 accepted

3 votes
Answer accepted

This did it. Thank you, I did a bunch of searches but never did see that!

@Mohamed Benziane - Does this hold true if I am already a Jira administrator?  That seems redundant to be in every group if I am an administrator.

V/R
Paul Stansberry
Edmond, OK

Like # people like this

Hi @Paul Stansberry 

I just tried it and you still need to be in each group with which you want to share the filter

That is very annoying.

As an administrator I shouldn't be member of each group or project role, I need to share a filter or a dashboard with.

In these cases "sharing" actually means "granting access".


I am a consultant customizing Atlassian Cloud environments for my customers.

I can't be member of their "all eployees" group, which is also synced from their AD. But I need to grant access to filters for this group all the time.

Like Frans Flippo likes this
1 vote
edwin vasquez Community Leader Jan 30, 2020

Hello @Newlyn Erratt ,

Does the group populate at all when looking for it? Can you post a screenshot? Is there an error message?

Done, threw up a list of everything in the original post. bfi-dallas is the one I want to add but it doesn't show up in the dropdown and if I type it out it says no group found. 

Like edwin vasquez likes this
edwin vasquez Community Leader Jan 30, 2020

Thanks for that. Try this. Fully type the name of the group and then try to add it even though it doesn't populate. I've had that issues before and just manually typing it does the trick for me.

Like Newlyn Erratt likes this

The add button just does nothing in this case. Even tried saving to see if the ui just wasn't updating but it doesn't add.

edwin vasquez Community Leader Jan 30, 2020

One suggestion I've seen is to add yourself to that group temporarily and then search for that group and see if you can add it. This looks to be an ongoing issue/request

https://jira.atlassian.com/browse/JRASERVER-15900

Like Newlyn Erratt likes this

That did it. Thank you!

Like edwin vasquez likes this
edwin vasquez Community Leader Jan 30, 2020

Awesome! Glad we figured this out.

Howdy, I've been having similar issues but with Roles not Groups. https://community.atlassian.com/t5/Jira-questions/Can-t-Add-Specific-Role-to-Filter-Shares-v2/qaq-p/1653839

No offense, but isn't what Edwin describes 3 threads above a complete hack? Why do I have to be a part of a Roles pool in order to assign a Filter Share (Viewer or Editor) for a given Role, (esp since I 1. own the project 2. am project lead 3. have myself set in the Administrators Role)? Shouldn't any of 1 ~ 3 allow me to set the Filter Shares as I see fit?

What efforts are being made to fix this bug? I would not consider this issue Solved.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events