Population User picker field with JIRA Automation

Karen Kelly March 8, 2024

I have a Multi Select field that I use on a JIRA service Management form to select employees to review work. I needed to set default people so the Multi User picker field did not want to display defaults on the form, thus I opted to use a Select List with Checkboxes.

I am able to get all the values of the checkboxes e.g.

User 1

User 2

User 3

But now that I want to assign these fields back to a user picker field it just says 'Inactive User on the Automation log.

See attached the Description populates perfectly with the employee names but just the User picker fields don't want to even though the display names are the sameScreenshot 2024-03-08 at 16.27.13.png

 

I even tried using Smart Variables e.g. One = {{issue.customfield_11992.value.get(0)}} and then set Assignee 1 (UP) = {{One}} with no success even though the display names are the same

 

It seems to work if you replace the user names with email addresses but I was hoping to use the names?

2 answers

1 vote
C_ Derek Fields
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 8, 2024

Try 

{{issue.customfield_11992.value.get(0).accountId}}
0 votes
Karen Kelly March 8, 2024

I even tried variables e.g. One = {{issue.customfield_11992.value.get(0)}} and then Assignee 1 (UP) = {{One}} but it renders the same issue

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS
AUG Leaders

Atlassian Community Events