How can I remove an unknown security type from my permissions?

I've been working on this for the past couple of days now and have gotten nowhere. I'm unable to use my service desk because the permissions are incorrect but when I try to go to the edit permissions page to remove the problem permission the page is blank. The faulty permission is 

  • Unknown security type (sd.customer.portal.only)

When I go to the permissions page the server also gives a Null Pointer Exception in the catilina.out log file.

I've tried deleting it from the database, editing the permissions xml file, reinstalling JIRA Service Desk and nothing works. Has anyone else had this much trouble with this issue and any suggestions. I'm using JIRA Software 7.2.1 and Service Desk 3.2.1 .

1 answer

1 accepted

1 votes

Hi Koby,


It is possible that Service Desk has not started or been installed properly. Few things to check:

 

>>Check to see if all Service Desk modules are running, this is done in the Jira admin -> manage add-ons -> (here select All Add-ons) then look for anything with Service Desk in the name and see if anything is disabled

>> Go into the database and run select * from pluginstate;
checking for any plugins that are disabled in the database.

Restarting Jira may fix this as it will restart the service desk plugins if they aren't started, but if they are actually disabled we'll need to enable them before starting back up

>>What you see when you expand the project sidebar

>>What you see when clicking Request Types

>>From the list of permissions, do you see a Service Desk Agent permission (should be right below Manage Sprints)?

>>What you see from Administration -> Applications -> Versions & licenses page

>>From Administration -> Applications -> Application access page, do you have application access to SD?

Checking reported issues, I saw one Service desk customer experienced very similar symptoms, getting the blank page, the null pointer exception in the log and the error about the "Unknown security type (sd.customer.portal.only)"... and then issue got resolved after Jira Restart, Perhaps in their case, it was as simple as Service Desk was not properly enabled so by restarting JIRA it has been enabled and working again.

Regards,

Mahtab

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Thursday in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

320 views 0 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot