Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Activity Stream is empty after upgrading from 7.4.2 to 7.12.0

I worked throuh the following topics:

(1) https://community.atlassian.com/t5/Jira-questions/Why-my-activity-stream-is-empty/qaq-p/286668

  • integritycheck - clear
  • reindexing - clear
  • restart - clear

(2) https://community.atlassian.com/t5/Jira-Software-questions/JIRA-Activity-Stream-gadget-empty-after-upgrade-to-7-4-3/qaq-p/635030

  • added above string to registry
    Set-ItemProperty -Path HKLM:\System\CurrentControlSet\Services\HTTP\Parameters -Name UrlSegmentMaxLength -Value 4096

Anything else works correct, but the activity stream is empty and gives no information about the problem

2 answers

1 accepted

1 vote
Answer accepted

I resolved the issue with powershell:

I ran the powershell command on our system and rebooted. After that the Activity Stream works as usual

Set-ItemProperty -Path HKLM:\System\CurrentControlSet\Services\HTTP\Parameters -Name UrlSegmentMaxLength -Value 4096
1 vote
Keri Atlassian Team Sep 14, 2018

Hi Christopher, 

 

We sometimes see issues with this if you have a proxy set up or other networking. If you try to access Jira directly from the server itself do you have any issues?

 

Are there any errors in the atlassian-jira.log with regards to the activity stream?  Are there any timeout or networking errors? 

 

JIRA Activity Stream returns one or more activity sources were slow to respond and are not included

 

Cheers,

Keri

grafik.png

This is quite interesting. The acivity stream is blocked by the csp (content security policy), when accessing from the server via localhost. Any suggestions how to fix that?

Keri Atlassian Team Sep 17, 2018

Hey Christopher, 

 

What is your Jira Base URL set to?  If you connect through the Base URL, is it blank instead of displaying this error?

We have some information here:

https://confluence.atlassian.com/jirakb/security-headers-in-jira-939919914.html

 

Cheers, 

Keri

What is your Jira Base URL set to?

It is set to https://www."mydomain"/jira

If you connect through the Base URL, is it blank instead of displaying this error?

This is correct. From server it shows the above error. From Base URL it is simply blank.

We have some information here:

https://confluence.atlassian.com/jirakb/security-headers-in-jira-939919914.html

Thanks for the link. I tried to disable the security headers in setenv.bat by adding

"-Dcom.atlassian.jira.clickjacking.protection.disabled=true" to line set JVM_SUPPORT_RECOMMENDED_ARGS=

Then I restart the Jira service. It is still blank from URL and offers the above mentioned error via localhost. Just to confirm, is it correct to add the statement in setenv.bat when starting Jira as a service?

Some additional information:

Our Jira is installed on Windows Server 2016 and runs via IIS.

Just to confirm, is it correct to add the statement in setenv.bat when starting Jira as a service?

Got it: for configurations regarding Jira as service look here under "Windows service"

I tried 2 options for configuring the service (then shut down and restart the service):

1. added -Dcom.atlassian.jira.clickjacking.protection.disabled=true
Result: still not working


2. added -Dcom.atlassian.jira.clickjacking.protection.exclude=/rest/gadgets/1.0/g/com.atlassian.streams.streams-jira-plugin:activitystream-gadget/gadgets/activitystream-gadget.xml

(I put in the xml-Link from Gadget-Menue)
Result: still not working

Hi Christopher, 

To determine whether there is something happening at the proxy level, if you could temporarily set up an unproxied connector for the purposes of the test. At least then we can discount proxy issues here, it wouldn’t be instead of your proxied connection - so users would still be able to access Jira as normal, it would just be in addition for testing purposes.

See our KB article for more details: How to bypass a reverse proxy or SSL in Application Links

If you bypass IIS completely, do you still receive the same error?

Can you also check your IIS configuration against the following guide: Integrating Jira applications with IIS?

You may also wish to check this IIS setting:

  1. Backup the Registry
  2. With Regedit, browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP\Parameters
  3. Find the value for UrlSegmentMaxLength, or if it doesn't exist add a DWORD value with this name and change it to 00001000 (this is the hex for 4096)
Also, sometimes Windows can be a little tricky when adding in parameters - can you try restarting the server completely?
Cheers, 
Keri

Hello @Keri sorry for the delay..

If you bypass IIS completely, do you still receive the same error?

I added a connector to port 8081 and accessed Jira within the server on localhost:8081/jira. There the activity stream loaded successfully.

As mentioned in my first post, I already add the value for UrlSegmentMaxLength.

Maybe you can have a look on my server.xml:

<Service name="Catalina">
       
<Connector port="8080" maxThreads="150" minSpareThreads="25"   connectionTimeout="20000" enableLookups="false"
maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443" acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="false" scheme="https"
proxyName="###Domain-Name (example: google.de)###" proxyPort="443"/>
     
<Connector port="8009" enableLookups="false" redirectPort="8443" protocol="AJP/1.3" />          

<Engine name="Catalina" defaultHost="localhost">

<Host name="localhost" appBase="webapps" unpackWARs="true" autoDeploy="true">

<Context path="/jira" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">
<Resource name="UserTransaction" auth="Container" type="javax.transaction.UserTransaction"                              factory="org.objectweb.jotm.UserTransactionFactory" jotm.timeout="60"/>
<Manager pathname=""/>
<JarScanner scanManifest="false"/>
</Context>

</Host>

<Valve className="org.apache.catalina.valves.AccessLogValve"
pattern="%a %{jira.request.id}r %{jira.request.username}r %t &quot;%m %U%q %H&quot; %s %b %D &quot;%{Referer}i&quot; &quot;%{User-Agent}i&quot; &quot;%{jira.request.assession.id}r&quot;"/>

</Engine>

</Service>

Hello @Keri,

 

I discovered another thing:

when adding -Dcom.atlassian.jira.clickjacking.protection.disabled=true to the service java option, the activity string shows

Jira_activity_stream_message_with_java_option.PNG

when accessing via localhost 8080. 8081 works fine.

Accessing from Base-URL via Web shows nothing.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Software

Presenting the "Best of 2020" Jira Software roundup!

Catch up with Atlassian Product Managers in our 2020 Demo Den round-up! From Advanced Roadmaps to Code in Jira to Next-Gen Workflows, check out the videos below to help up-level your work in the new ...

4,778 views 5 15
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you