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Unable to see any KB Articles listed on the Service Project

Summary of Issue

No knowledge base articles are listed within the Knowledge Base page on a Service Project. How would this situation happen?

Screenshot 2023-09-21 at 6.56.21 AM.png

Root Cause

This happens when a customer has their Confluence Product deactivated and reactivated and their Confluence space is also renamed when the product is re-activated. 

This scenario causes the KB Articles to not appear within the Pages section within the Confluence Space, as well as their URLs to the KB Articles in Confluence are pointing to the old space name. This disconnect causes the Articles to not show in the Knowledge Base section on a Service Project.

Solution

The way to go about solving this case is to do two things to ensure all KB Articles are visible within the Service Project.

  1. Reorder the KB Articles on the Page tree in Confluence. For example, moving an Article from the top of the Page tree and back to its original place. This solution will cause a re-index to the Knowledge Base and its connection to Confluence.
  2. Make a "dummy" page publish to the articles that are not showing in the KB Space on the Service Project. This will update the URL extension to the correct Space name and will display those KBs in the JSM KB space on the Service Project thereafter.

Screenshot 2023-09-21 at 6.54.28 AM.png

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