Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,409,326
Community Members
 
Community Events
169
Community Groups

Integration with Qase

Hi,

I'm using JIRA cloud and Qase (a QA tool for documenting test cases etc.). I'm trying to set up an integration so that bugs reported in Qase are sent through to JIRA.

This is the integration page in Qase:

Screen Shot 2020-10-22 at 9.58.57 am.png

When I try the 'Test connection' button, it comes back with "Jira host is not available. Please, check connection settings (404)".

  • For JIRA host, I copy the prefix of the URL for my JIRA cloud account. I'm not sure if this is correct - based off forum searching.
  • For Username, I use the prefix of my email address (e.g. joe.bloggs@gmail.com = joe.bloggs). I'm not sure if this is correct - couldn't find my username in JIRA cloud since it seems like that is removed/hidden based off forum searching.
  • For API token I'm generating the API token using this guide . I think this is correct.

Can someone please help point out which field/s I've got wrong, and how I find the correct JIRA host/Username for JIRA cloud?

 

Thanks in advance,
Joe

4 answers

1 accepted

1 vote
Answer accepted

As for the url, I think you should remove the jira and write till

xxxxxxxxxx.atlassian.net

Thanks, this suggestion helped a bit. Instead of getting "Jira host is not available. Please, check connection settings (404)", I'm now getting "Connection credentials are invalid. (401)".

 

Since it's recognising the Jira hostname now, and I'm pretty sure the API token is correct, I think I just need to get the username right.

 

Thanks for your help looking into this :)

Adding the comment from the other thread for anyone else trying this:


As Joel said, JIRA hostname is: xxxxxxxxxx.atlassian.net
Username is the email address you use to log in to JIRA

API key you can get by following the guide.

Hello, Joe!

My name is Nikita and I'm from Qase. I understand that the question was asked a year ago, but I think that my response will help people who see this ticket.

We have released a native Jira Plugin that can be installed from the Atlassian Marketplace: https://marketplace.atlassian.com/1226612

Best wishes,
Nikita.

Still, if you don’t want to use zapier and use the integration you are currently using, here are some steps👇

To find your username : 

  • Click on your picture in the top right side
  • select personal settings
  • Your user name will be shown there 

I followed the steps you suggested but the username doesn't display:

 

Screen Shot 2020-10-22 at 10.34.54 am.png

Wait, let me troubleshoot it

Like Joe Tuke likes this

Ok, try if this works

1.

 

630F6AC3-86BE-49E5-A1BC-55BCF0305B8B.jpeg

Hmm... no dice. I tried copying both the Full name / Public name and using those as the credentials but still got the unauthorized error.

 

My original assumption was the the Full name / Public name was different to the username.

May I ask if you are a admin

Yes, I set up the account, and double-checked I have site admin access in settings > user management.

Screen Shot 2020-10-22 at 10.57.19 am.png

If you are then 

click on settings beside the profile pic and choose user management

then scroll to the desired user and click on view details

after that you can scroll down and you will see a image in which his avatar, his email, and also one more thing Will be present there { @Support - Leoj Studio}

copy paste that 

Thanks, I tried that but it didn't work.

 

I managed to figure out the answer though, the username was my email address. I was able to connect after putting that in.

 

Thanks for all your assistance :)

Hey @Joe Tuke ,

To start off, I would prefer you to use Zapier , It is a free integration software where you can link two apps, as for username Zapier only asks for your connected account with Jira.

Thanks for your suggestion Leo. Qase is not supported by Zapier, so I don't think this solution would work for me.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events