[velocity mail template] missing line breaks in $issue.getDescription()

Hi there,

any idea of getting some information about the formatting or line breaks?

thanks Fredy

3 answers

1 accepted

Accepted Answer
0 votes

My Solution is:

#if ( $rendererManager.getRenderedContent("atlassian-wiki-renderer", $issue.getDescription(), $issue.getIssueRenderContext()) )
$rendererManager.getRenderedContent("atlassian-wiki-renderer", $issue.getDescription(), $issue.getIssueRenderContext())
#else
description is missing...
#end

I think this should be possible with:

$wikiStyleRenderer.convertWikiToXHtml($renderContext, $issue.getDescription());

But it's not working yet! I will start a task "How does $wikiStyleRenderer.convertWikiToXHtml work?"

You can do this .!
#set( $foo = $!issue.description )

#set ($desc = $foo.replace("

", "<br/>") )

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Featured Groups

Tuesday tips & tricks: What is the Atlassian Community?

It's officially Tuesday, which means it's officially time for another tip to help you better navigate this space we call the Atlassian Community. 😄 I got a great question from community member, Sa...

51 views 2 4
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you