Problem facing with CSV file import to JIRA...

Hi,

I am trying to import data from CSV file to JIRA, During the 3 rd step I have encountered with an error shown as below :

Invalid project key PRJA-1: You must specify a unique project key, at least 2 characters long, containing only uppercase letters

And I have changed the key with some new values & tried to import, This time in the first step only I have encountered with error :

java.io.IOException: Malformed CSV stream. Missing [,] near offset 9 after field 0 on line 1

please help me on this.

Thanks in Advance...

8 answers

1 accepted

This widget could not be displayed.

Your CSV is not well formatted it seems? Are you able to open it in Excel?

Thanks for the Response Jobin. And Yes I am able to open it in Excel. By the way I am using JIRA 4.4.3 working on Windows7...

This widget could not be displayed.

Could you please paste here first 2 lines of your CSV file?

Another question: which version of JIRA Importers Plugin do you use with JIRA instance? It's probably 3.5.x, but recently we were shuffling with CSV parser libraries used, so this information is quite important.

This widget could not be displayed.

Hi Wojciech Seliga, thanks for your response. Now it is working fine for me. The 1st issue that I have mentioned is due to invalid format of CSV file.

But for the IOException mentioned above I am still getting that, if I do any modification to the field of the CSV file which I have already used and tried to use again...

I am using JIRA Importers Plugin 3.5.3...

This widget could not be displayed.

As Wojciech says, we need to see your data to tell you where the problem is? The error message is telling you that the data is incorrectly formatted, so we need to see it to be able to point you at the error.

This widget could not be displayed.

<colgroup><col width="64"><col width="37"><col width="78"><col width="88"></colgroup>
Project Key Summary Issue Type
ProjectA PJA Summary1 Requirement
ProjectA PJA Summary2 Defect
ProjectA PJA Summary3 Task

Here I am providing my CSV file data...

This widget could not be displayed.

That's not CSV - could you give us the plain text CSV, not just formatted data? We need to see exactly what Jira is reading from the file, not what you think it should be reading.

This widget could not be displayed.

Thanks Nic, It is working now. The file is not formatted correctly the fields are seperated by a semicolon instead of comma.

This widget could not be displayed.

I'm having the same problem. This is my two first lines:

<colgroup><col width="211"> <col width="174"> <col width="264"> <col width="105"> <col width="181"> <col width="157"> <col width="80"> <col width="64"> <col width="138"> <col width="139"> <col width="64"> <col width="239"> <col width="151"> <col span="6" width="64"> </colgroup>
Project Key Summary Priority Created Component/s Description Category Status Browser/s or Device/s Operational system/s Attachment 1 Attachment 2 Attachment 3 Attachment 4 Attachment 5
Buscape Mobile iOS BUSCMOB-1 [Texto] Alguns textos na tela inicial estão em plural e outros não Minor 17/07/2012 09:54 Tela Inicial EXPECTED:
Um padrão na tela inicial, todos produtos no plural ou nenhum.

ACTUAL:
Alguns produtos na tela inicial está em plural e a maioria não.
User Interaction Open IPhone 3GS iOS attachments/BUSCMOB-1/21309.jpg attachments/BUSCMOB-1/21307.jpg attachments/BUSCMOB-1/21308.jpg attachments/BUSCMOB-1/21311.jpg attachments/BUSCMOB-1/21310.jpg
Buscape Mobile iOS BUSCMOB-2

[Botões] Botão 'Busca' não é

intuitivo

Major 17/07/2012 10:24 Tela Inicial EXPECTED:

Botão 'Busca' poderia ser chamado de 'Home' visto que o botão 'Busca' retorna para a página inicial.



ACTUAL:

Botão 'Busca' passa a impressão de ser um título da seção e não um botão que retorna a página inicial.
User Interaction Open iPad iOS attachments/BUSCMOB-2/21304.png

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Teamwork

What teamwork quotes inspire you?

Hey everyone! My name is Natalie and I'm an editor of the Atlassian Blog and I've got a question for you: What's your favorite quote about teamwork?  We've compiled a list here, along with...

28 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you