JIRA notification mail stuck in queue


We have a probleme with the notification mail in JIRA 5.2.

The notification mail are stuck in queue. The only way to send notification is to manualy flush mail queue or restart JIRA service.

  • The Mail Queue service is set to 1 min.
  • The SMTP test work fine
  • JIRA is running within a VM on Windows (dont have the "time jump" issue in the log).
  • I don't have any mail related error in log.
  • JIRA have enought ressources

Do you have any solutions ?

Thank you :)


8 answers

1 accepted

The memory can be checked on $JIRA_HOME/bin/setenv.bat. Increase the following argument:

    This will require your JIRA to be restarted.

I increased JVM_MAXIMUM_MEMORY from 746m to 1256m.


We hit the same problem and could not restart JIRA (business limitations)

It turns out the mail queue has crashed. Changing interval of mail queue service to some other value forced it to to restart and it started working right away without a complete JIRA restart

That did it for me. Perfect.

I experienced a stuck mail queue after upgrading from 6.4 to 7.1.9 and a quick change of the mail queue service schedule fixed it. Thanks.

I've read this post.

I don't have the "time jump" issue in the log.

How can i Disable time synchronization with time server. ?

Thank you :)

0 vote
Daryl Chuah Atlassian Team Jan 06, 2013

Hi there

You can double click on the bottom right corner the data/time area, then a Date and Time window will popup

Under Internet Time tab, click on "Change settings", uncheck the "Synchronize with an Internet time server" option and click OK.


Daryl Chuah


I tought it was a setting in JIRA, not a server setting.

The time is synchronized with a NTP service.

Any other idea ?

Ty :)

My server is not synchronize with an internet time server.

0 vote

Hi Luc,

Based on this KB, to disable the time synchronize with time server, please see:

  1. For Microsoft : http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/windows_date_turn_off_synch.mspx?mfr=true
  2. For Linux : http://ubuntuforums.org/showthread.php?t=1335737

Hope its help.

Hi Luc,

I'm just curious if you managed to resolve this issue? It seems that I've faced exactly the same problem.

Hi Pavel,

I think it was a plugin problem.

I disabled all plugin and I reactivated one by one and i tested.

An SVN plugin took too many resources.

You can also try to increase the JVM_MAXIMUM_MEMORY.

I hope it can help you.

Thanks, Luc. Will try the same.

Suggest an answer

Log in or Join to answer
Community showcase
Maarten Cautreels
Posted Thursday in Off-topic

Friday Fun: What's your favourite beer/drink

As a Belgian, beer-lover and home brewer, beer is one of my great passions. I love the fact that with just a few ingredients (usually just water, hop and malt) you can create so many different tastes...

285 views 38 9
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot