Error installing Atlassian Connector for Eclipse

Hi,

I need to add some Atlassian plugin onto my Eclipse IDE.

The Eclipse version is
Version: Helios Service Release 2
Build id: 20110218-0911

When I try to install the following plug-in:
Atlassian Connector for Eclipse 3.0.8.v20130328
I get the following error:

Cannot complete the install because one or more required items could not be found.
Software currently installed: Atlassian Connector for Eclipse (Required) 3.0.8.v20130328 (com.atlassian.connector.eclipse.feature.group 3.0.8.v20130328)
Missing requirement: Atlassian Connector for Eclipse Branding 3.0.8.v20130328 (com.atlassian.connector.eclipse.branding.ui 3.0.8.v20130328) requires 'bundle org.eclipse.mylyn.commons.workbench [3.8.0,4.0.0)' but it could not be found
Cannot satisfy dependency:
From: Atlassian Connector for Eclipse (Required) 3.0.8.v20130328 (com.atlassian.connector.eclipse.feature.group 3.0.8.v20130328)
To: com.atlassian.connector.eclipse.monitor.feature.group [3.0.8.v20130328]
Cannot satisfy dependency:
From: Atlassian Connector for Eclipse Usage Data Collector 3.0.8.v20130328 (com.atlassian.connector.eclipse.monitor.core 3.0.8.v20130328)
To: bundle com.atlassian.connector.eclipse.branding.ui 0.0.0
Cannot satisfy dependency:
From: Atlassian Connector for Eclipse Usage Monitoring 3.0.8.v20130328 (com.atlassian.connector.eclipse.monitor.feature.group 3.0.8.v20130328)
To: com.atlassian.connector.eclipse.monitor.core [3.0.8.v20130328]

Could you advise how I can work around this issue? If other atlassian artifacts are needed, which repository I should use to get them?

Regards

1 answer

Hi,

What is your JIRA version? If it is 5.0 or newer then please try following update site: http://update.atlassian.com/atlassian-eclipse-plugin/rest/e3.7

If the issues are still there then please try our latest nightly build (it has improved dependency setup): http://update.atlassian.com/atlassian-eclipse-plugin/rest/nightly/e3.7

If your JIRA is below 5.0 then please let me know your Mylyn version and I will try to look closer into the problem.

Cheers,
Jacek

Thanks for the reply.

The Jira version we are using is v4.1.2#531.

I have a couple of Mylyn features installed (such as mylyn.ide_features, mylyn.java_features etc). Which Mylyn version is of best interest to you?

If you are talking about org.eclipse.mylyn, the version is 3.4.0.

Please let me know if you need further information

Mylyn 3.4.0 is tool old. Could you please upgrade to 3.8 or newer and try to install Connector once again?

Thanks,
Jacek

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Canada

Happy New Year - First AUG of the year - great success

Hi Everyone, Hope everyone had a great holiday season and is ready for an exciting 2019.  We had our first AUG last night featuring Tempo Timesheets.  A great presentation and lots of int...

18 views 0 1
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you