Add Gadget from another Jira instance

Hi,


I want to add a Gadget from one of my Jira instance to another Jira instance. I'm in the ''Add Gadget to Directory'' popup screen. I paste my XML link and click ADD GADGET button. I got a popup error message saying 'sorry, we were not able to add gadget to directory'

When I tried to add the same gadget on a third Jira instance (setup the same way, same jira version) it can add the gadget without any problems, it works fine. I tried with different other gadgets and it's doing the same behavior.

I have no idea why it works fine on an instance, and not on the other. Any body have a clue on this?

Thanks in advance!

1 answer

any suspicious log lines available?

i mean from the host where your jira instance is running that won't add the gadget...

try accessing the gadget-url directly...

the only thing i can see in the log is :

''Caused by: com.atlassian.gadgets.GadgetParsingException: org.apache.shindig.gadgets.GadgetException: Unable to retrieve gadget xml. HTTP error 503''

could you reach the gadget-url with something like wget or curl?

well, i can access the gadgt-url without any problem.

i can add the same gadget on another jira instance without any problem also.

im using jira 4.2.4

yep, I can access the gadget url directly

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published 14 hours ago in Off-topic

Get to know our Atlassian User Group Leaders from Bengaluru, India

Meet @Dinesh Dhinakaran, @Vishnu Vasudeva, @Rajeev Verma, and Jamshid Nalakath: Our extraordinary AUG leaders from Bengaluru, India. These four work together to strengthen the bonds of their local co...

102 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you