Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

zoho to jira intergration

Hi Guys,

Currently we have zoho sprint and we're running project on zoho but now we have bought the zira enterprises software. we want to import/integration zoho sprint to Jira software. is there any way to achieve that ? I googled it i found only jira to zoho not vice versa.

Regards

Pankaj

2 answers

1 accepted

0 votes
Answer accepted

Hi @Tanu Gupta ,

I can see that this question has already been asked in the past and more or less the outcome was that you can export your Zoho data as CSV and you can then use JIRA's importer to perform a CSV import.

For further details you can review the original thread: What is the easiest way to transfer our (Bug) database from Zoho to JIRA?

Also, by searching the marketplace I have found an add-on named "Zoho Desk Jira Integration" that might be helpful in this situation but, since I am not sure on how this works and what your requirements are, I'd advise to review the documentation and/or get in touch with the add-on vendor: Zoho Desk Jira Integration - Support

 

I hope this helps.

 

Cheers,
Dario

Hi Dario,

I'm stuck on this step where jira asking for Summary field and I'm not able to understand where to define this value and how ? i also checked the document based on this issue but still not getting it. i have csv file to import zoho to jira using that file. Could you please send me a file where i see how to setup csv file to import in jira. I'm attaching the Screenshot. i also tried by creating a custom summary field in jira field but didn't work.

 

jira.JPG

Excel file format

 

jira1.JPG 

 

Regards

Tanu

Hi @Tanu Gupta ,

Can you open the CSV file with a text editor and make sure it is a valid CSV and that commas are used as separator? 

For example, I can see in your second screenshots that there are 3 values on the top of the excel file that I would not expect to see there.

Also, according to the first screenshot, Jira is not able to get the fields from the CSV to import. While if the correct file and delimiters are provided then you should be able to see the different fields in the Fields mapping screen.

 

Example:

1) I open a text file, I enter below values in there  and I save it as test.csv:

itemid, item name, Description, Sprint
xxx123, Something, A generic descritpion, sprint-name
xxxx234, Something else, Another description, sprint-name

 

2) In Jira I go to External System Import  and I choose to import from CSV

 

3) I select to import from test.csv (the file created in step #1) and I expand the Advanced section to make sure the correct delimiter is set (comma in my case):

CSV-delimiter.jpg 

 

4) After I am done with the Setup section I then get the fields correctly recognized to be mapped to the  existing Jira fields:

CSV-Fields.jpg

 

 

Please check that the provided file is a correct CSV file and make sure the correct delimiter is set in the CSV importer and let us know if this solves the issue. Provide more details otherwise.

 

Have a nice day.

Dario

Hi @Dario B 

Thanks for your reply, we already did the same thing which you have mentioned in the reply but the problem is Summary field mapping. This is the first line in my csv file mentioned below.

ItemId,Item Name,Description,Sprint,Assignee,Created by,

and saved by .csv and encoded by UTF-8 but the problem is still same.

jira.JPG

After clicking on Next,

 

jira1.JPG

then click on next

jira2.JPG

There's an issue with summary field and also we're getting only few filed to map which are defined in csv file.

I also tried this one too

Summary,ItemId,Item Name,Description,Sprint,Assignee,Created by,

But the problem is same and next button is grey out.

it will be helpful if you provide us some template or document  with excel format to import the data.

Please provide the solution on urgent basis.

Regards

Tanu

Dario B Atlassian Team Jun 27, 2019

@Tanu Gupta ,

 

As already mentioned, the problem here is that the fields are not recognized at all and, as the error  message says, you must have at least the summary field in order to run the import.

Now, maybe the provided examples are incomplete, but in there I can see 2 things that can explain the message printed in the last screenshot above: "First row does not have a value"

  1. They are only showing the first row, therefore only the row defining the fields. If this is the sample file you are trying to import then indeed there are no values in the first row (since it is empty)
  2. There is a comma after the last value (Created by) and this way everything is seen as a sigle row.

 

Please copy the text below in a text file (e.g.  using notepad. Do not use any editor that adds formatting) and save it to CSV. Run the import and confirm this works. Make sure to leave the extra empty line at the end of the file

ItemId,Item Name,Description,Sprint,Assignee,Created by
xyz1,just an item name,this is the description of the item,sprint n1,username here,someone
xyz2,another item,this is the description of the item,sprint n2,username here,someone

 

Finally, please notice that:

  • We don't support importing from any Excel format. Only CSV. You can open a CSV file with Excel but this is not an Excel format
  • I already provide an example of a working CSV file in my first reply
  • This is a community forum, if you need urgent help or similar  you might want to open a support ticket  by going to: https://support.atlassian.com/contact/

 

Dario

Dario B Atlassian Team Jul 04, 2019

Hi @Tanu Gupta ,

I can see that you are getting in touch with the Atlassian Partners to get help importing from Zoho. Therefore I am marking this as solved. 

Cheers,
Dario

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you