Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

where is the megaphone icon of the announcement?

After the upgrade to JIRA Service Desk 4.5.1 the megaphone icon of the announcement is missing.

Is that a feature of this version or is it my mistake? Do you have any ideas?

2 answers

0 votes

Hello Loredana,

Thank you for reaching out to Community!

Searching using the details you provided, I didn't find anything related to this issue and no one reported it to us as well.

Just for us to better understand, is it happening for everyone that accesses the customer portal? 

Is it not showing for users and also for customers only?

Was there any new add-on recently installed that could cause this issue?

Regards,
Angélica

Thanks Angelica,

yes, is it happening for everyone that accesses the customer portal.

Megaphone icon of the announcement Is not showing for users and also for customers.

The issue appears after the upgrade of jira server from 7.13.1 to 8.5.1 and Jira Service Desk from 3.16.1 to 4.5.1

Best regards

Loredana

Thank you for the details, Loredana.

We tested here the same version and the icon is showing correctly, so something happened during the upgrade that caused this.

As a test, please check if there are any updates for the add-on "Support tools plugin" and also for other add-ons and update all.

Also, check the Failed Plugin Report section in startup logs in order to see if there is anything flagged.

Another thing to check that can fix it is to reset the plugin cache:

  • Stop Jira
  • Remove the *.bundled-plugins* and *.osgi-plugins* manually in the *<JIRA Home>/plugins* directory (These are hidden by default):
  • $jira-home/plugins/.bundled-plugins
  • $jira-home/plugins/.osgi-plugins
  • Delete the contents of the work directory (!) Only remove the contents, do not remove the directory itself, or the path will not rebuild correctly:
  • $jira-install/work/*
  • Restart your JIRA instance

Please, give it a try and let us know how it goes.

Hi Angelica,

I have applied all the steps indicated in your answer but the problem persists. Everything seems to work but the megaphone icon is not there. I can also leave it alone because everything else works but I'm a bit worried about not understanding where the problem is.

Do you have any other ideas?


For completeness I add that in the catalina log, after the restart of Jira instance, we have :

___ FAILED PLUGIN REPORT _____________________

1 plugin failed to load during JIRA startup.

'com.atlassian.applinks.applinks-diagnostics-plugin' - 'Applinks Diagnostics Plugin' failed to load.
Application context initialization for 'com.atlassian.applinks.diagnostics-plugin' has timed out waiting for (|(objectClass=com.atlassian.applinks.spi.link.MutatingApplicationLinkService)(&(objectClass=com.atlassian.applinks.spi.util.TypeAccessor)(objectClass=com.atlassian.applinks.core.InternalTypeAccessor)))

It has the following missing service dependencies :
&applicationLinkService of type (objectClass=com.atlassian.applinks.spi.link.MutatingApplicationLinkService)
&applicationLinkService of type (objectClass=com.atlassian.applinks.spi.link.MutatingApplicationLinkService)
&typeAccessor of type (&(objectClass=com.atlassian.applinks.spi.util.TypeAccessor)(objectClass=com.atlassian.applinks.core.InternalTypeAccessor))
&typeAccessor of type (&(objectClass=com.atlassian.applinks.spi.util.TypeAccessor)(objectClass=com.atlassian.applinks.core.InternalTypeAccessor))

It was loaded from /opt/jiraHome/plugins/installed-plugins/plugin.7251675514068973601.applinks-diagnostics-plugin-5.1.1-m001.jar
3 plugins are unaccounted for.
Unaccounted for plugins load as artifacts but fail to resolve into full plugins.

'com.innovalog.jmcf.jira-misc-custom-fields' - 'JIRA Misc Custom Fields' is unaccounted for.

It was loaded from /opt/jiraHome/plugins/installed-plugins/plugin.7618287458048671265.jira-misc-custom-fields-1.7.2.jar

'com.keplerrominfo.jira.plugins.keplercf' - 'Power Custom Fields' is unaccounted for.

It was loaded from /opt/jiraHome/plugins/installed-plugins/powercf-4.0.4-r20170828184555.jar

'com.invisionapp.integration.jira' - 'InVision for Jira' is unaccounted for.

It was loaded from /opt/jiraHome/plugins/installed-plugins/plugin.55629634084202732.com.invisionapp.integration.jira-3.0.0-master.jar

********************************************************************************************************************************************************************************************************

Thank you for the tests and information. 

We checked here and the Applinks diagnostic plugin has been removed from our Marketplace since 2015 due to a blocking bug.

When a plugin fails to start, it can block the full startup of other add-ons, so as this plugin is not on the marketplace anymore, you can remove it and do another plugin cache flush that I sent on the previous response.

To remove the add-on you need to manually remove the .jar file:

/opt/jiraHome/plugins/installed-plugins/plugin.7251675514068973601.applinks-diagnostics-plugin-5.1.1-m001.jar

Also, the other three add-ons that show on the logs should be reinstalled with the latest version if you and your team are still using.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you