tempoEpicIssues() not working anymore?

We have been using this filter in a Project Board for over a year, and it stopped working yesterday/today. 

issue in ("Epic-ID") OR "Epic Link" = "Epic-ID" OR parent in tempoEpicIssues("Epic-ID") ORDER BY Rank ASC

Error message: Unable to find JQL function 'tempoEpicIssues("Epic-ID")'. 

Any changes this week related to the tempoEpicIssues() function?

7 answers

1 accepted

2 votes
Dave Meyer Atlassian Team Jan 02, 2017

Update 13 January 2017

I'm pleased to announce the parentEpic function is now available in JIRA Cloud.. Searching with parentEpic will return all the issues in the specified epic(s) AND their sub-tasks. The syntax is a little bit different than a standard JQL functions – it's more like searching with a field. So

project = JRA and parentEpic = JRA-123

will return all issues and sub-tasks in the JRA project that are in the JRA-123 epic. The function also supports the != , IN , and NOT IN operators. So you could also search something like

project = JRA and parentEpic in (JRA-123, JRA-456) 

and you will get all issues and sub-tasks in either the JRA-123 or JRA-456 epics.

Refer to the documentation for more information. Happy searching!

Dave Meyer

Senior Product Manager, JIRA

warning Note: If your JIRA Cloud instance currently has a license for Tempo Timesheets, the tempoEpicIssues() JQL function should still be available. You can manually change your filters to use the parentEpic function, or wait until they are automatically updated as part of the migration to Tempo's new Cloud technology platform

Original message

The tempoEpicIssues function was provided by a paid third-party add-on called Tempo Timesheets that was previously pre-installed in JIRA Cloud. Using this add-on required purchasing a license from the Atlassian Marketplace, but due to an error this JQL function was available even if the add-on was not licensed.

As part of ongoing efforts to improve reliability, performance, and security for our JIRA Cloud offering, this add-on is no longer pre-installed on JIRA Cloud instances that do not have an active license for it, which is why the JQL function is no longer available.

We are working hard to implement a native JQL function developed and supported by Atlassian that provides the same functionality that you will be able to use to replace tempoEpicIssues. We expect to release this in the next couple weeks.

Thanks for your understanding and patience.

Dave Meyer

Senior Product Manager, JIRA

Thanks Dave. But I tried to install tempo timesheets (for cloud) yesterday and even after install, the old filters didn't work. Do we need to change the syntax now?

I just tried the same thing and with the same result; still didn't work.

Dave Meyer Atlassian Team Jan 02, 2017

Hi guys,

The new version of Tempo Timesheets for JIRA Cloud built on the new technology framework does not include the tempoEpicIssues function. We've developed a replacement for Tempo customers and non-Tempo customers alike and we are doing our best to get it released as soon as possible.

Unfortunately we did not realize that there was a licensing issue that allowed the function to be used on instances that did not have a license for the old version of the add-on, so when we removed the add-on for instances without licenses, the function stopped working. At this point, it will be faster for us to roll forward with our native replacement. I will comment again here once it's shipped.

Alright. Thanks for the update Dave!

Is there an issue for tracking this replacement  functionality, s that we can learn when it will be available?

Dave Meyer Atlassian Team Jan 12, 2017

Hi everyone, this function is now available. Please see my updated answer.

Any chance this can be extended to take a filter, instead of a literal list of epics? Our team bases much of its reporting on a pre-defined filter that queries for open epics –I would like to be able to query for linked tasks under this set.

Wonderful! Thank you!

Thanks for the fix.   One small issue.   I use this for creating swimlanes on a scrum board.   When I edit the filter for the swimlane if I don't capitalize the key value, I get an internal server error when I try to view the board.

parentEpic in (api-27) vs. parentEpic in (API-27).

I tested this with other queries and the small letters work fine.

Dave Meyer Atlassian Team Jan 18, 2017

Thanks for reporting that bug @Jane Sherman. I've created https://jira.atlassian.com/browse/JRA-63814.

Why parentEpic function can't be found in documentation any more by the provided link?

Page titles "Advanced searching - functions reference"  doesn't have this function.

Dave Meyer Atlassian Team Aug 12, 2017

Hi @Pavel Bulanov, the function is definitely still available and working fine. I'm working with our documentation team to see why it's no longer visible in the docs. Here's a screenshot of the documentation in the meantime:

Advanced_searching_-_functions_reference_-_JIRA_Software_Cloud_-_Atlassian_Documentation.png

Facing the same problem. Any solutions please?

Same problem here.   Very sad.    The strange thing is I believe it was working 2 days ago.  I just created a new board using this in the filter - definitely after 12/7.

This is broken for us as well.  It seems to still be working ok for the boards, but it is not working in search issues.  how about it Atlassian??? no response to another broken feature that we are counting on!!??

Same problem here!

I am having the same problem. Seems to have started around Dec 21 2016. 

Relying heavily on tempoEpicIssues(), so hoping for a quick resolution.

Same issue, feedback would be much appreciated!

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jun 14, 2018 in Jira Service Desk

How the Telegram Integration for Jira helps Sergey's team take their support efficiency to the bank

...+ reading Fantasy). The same is true for him at the bank he works for: Efficiency is key when time literally equals money. Read on to learn how Sergey makes most of the time he has by...

488 views 2 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you