jira authentication to bamboo

Hi everyone,

I am trying to link JIRA (6.3.4) to Bamboo (5.6.0) but I'm not 100% successful yet. The link is somewhat working, I can see now the "Build" link in the "Development" section of JIRA tickets.

However when I click on it, there is first a pop up that tells me:

Authenticate to see related builds
Please log in to approve this application: Atlassian Bamboo

I click on the Atlassian Bamboo link and a new tab opens up with the message"

image2014-11-6 10:43:41.png

I click "Allow", the tab disappears but the Build link in the JIRA ticket still prompts for the same Authentication, so it didn't do anything.

On the Welcome to Bamboo,  when I click on the Click here to view the application permissions, there is one entry for each time I click the "Allow" and each entry says:

JIRA expires in X days
Atlassian JIRA at null
There is a hint that something is not entirely right because it shows a "null".
But reading through tons of documents explaining the linking process, I just can't figure out what is still wrong.
Does anyone have suggestion on how to proceed from here?

2 answers

0 vote

Hey Fred,

 

Would you mind to perform the process of allowing your Bamboo on JIRA and then attach the atlassian-jira logs (or just the part related to this attempt) to this thread? I guess we would have some further details on what's happening there.

 

Otherwise, you might want to raise a new ticket on our Support Channel, so we can better assist you with this smile

 

Best regards,

Eduardo Mallmann

Hello Eduardo,

I went through the exercise and extracted the logs from both atlassian-jira.log and atlassian-bamboo.log.

Atlassian-jira.log says

2014-11-06 17:14:00,331 devstatus.applink:thread-1 WARN cmoran 1381x159x2 1fb3ely 172.28.81.107 /secure/AjaxIssueAction!default.jspa [apache.commons.httpclient.HttpMethodDirector] Unable to respond to any of these challenges: {oauth=OAuth realm="https%3A%2F%2Fadc-bamboo.adccorp.alarm.com"}
2014-11-06 17:14:00,331 http-bio-443-exec-1008 WARN fbleuzet 1034x187879x2 1xz4td3 10.15.10.240 /rest/dev-status/1.0/issue/detail [plugin.devstatus.provider.DefaultCoordinator] Requests failed: Atlassian Bamboo (unauthorized)
2014-11-06 17:14:03,810 devstatus.applink:thread-4 WARN cmoran 1381x176x1 1fb3ely 172.28.81.107 /rest/dev-status/1.0/issue/summary [apache.commons.httpclient.HttpMethodDirector] Unable to respond to any of these challenges: {oauth=OAuth realm="https%3A%2F%2Fadc-bamboo.adccorp.alarm.com"}
2014-11-06 17:14:03,810 http-bio-443-exec-1008 WARN fbleuzet 1034x187931x2 1xz4td3 10.15.10.240 /rest/dev-status/1.0/issue/detail [plugin.devstatus.provider.DefaultCoordinator] Requests failed: Atlassian Bamboo (unauthorized)

and the atlassian-bamboo.log says

2014-11-06 17:14:03,072 INFO [http-bio-443-exec-14] [AccessLogFilter] fbleuzet POST https://adc-bamboo.adccorp.alarm.com/plugins/servlet/oauth/authorize 110891kb
2014-11-06 17:14:03,181 INFO [http-bio-443-exec-69] [AccessLogFilter] 10.15.10.69 POST https://adc-bamboo.adccorp.alarm.com/plugins/servlet/oauth/access-token 106943kb
2014-11-06 17:14:03,540 WARN [http-bio-443-exec-44] [TrustedApplicationFilterAuthenticator] Failed to login trusted application: jira:13746119 due to: com.atlassian.security.auth.trustedapps.InvalidCertificateException: Request not allowed to access URL: /rest/jira-dev/latest/detail/build
2014-11-06 17:14:03,540 INFO [http-bio-443-exec-44] [AccessLogFilter] 10.15.10.69 GET https://adc-bamboo.adccorp.alarm.com/rest/jira-dev/latest/detail/build?globalId=DST-2571 103066kb
2014-11-06 17:14:03,867 INFO [http-bio-443-exec-48] [AccessLogFilter] fbleuzet GET https://adc-bamboo.adccorp.alarm.com/ajax/viewPlanUpdates.action?sinceSystemTime=1415312022882&lastProject= 102744kb
2014-11-06 17:14:10,966 WARN [http-bio-443-exec-67] [AuthenticatorImpl] No executing user assigned for 2LO requests
2014-11-06 17:14:10,966 INFO [http-bio-443-exec-67] [AuthenticatorImpl] Authenticated app 'jira:13746119' as user 'null' successfully
2014-11-06 17:14:10,966 INFO [http-bio-443-exec-67] [AccessLogFilter] 10.15.10.69 GET https://adc-bamboo.adccorp.alarm.com/rest/remote-link-aggregation/latest/aggregation?globalId=DSC-1182 100082kb

Do you see anything obvious? The InvalidCertificateException on the bamboo side is odd, all the certificates were signed by our same internal CA and of the JIRA, Confluence, Bamboo and Fisheye, only the link between JIRA and Bamboo is not 100% functional. So I'm not sure what certificate it is referring to.

Should I go ahead and file a ticket in your  Support Channel?

Hey Fred, Thanks for the logs. That's pretty weird, may I ask if you have already tried to recreate the application links between them, setting to use the OAuth authentication? I guess the best you could do in this case is to raise a ticket on our support channel, so we can investigate further details from your instances and assist you to get it working :) Best regards, Eduardo Mallmann

thanks for looking at it. I'm filing a ticket to the support channel.

I forgot to mention, yes, I did recreate the application link but it didn't change anything, the behavior remains the same.

Did you find a solution to this problem? Because I'm getting exactly the same problem too.

Hey Peter, yes, we eventually got it to work, there are 2 parts to it. At the time we create the link, we need to tell that JIRA and Bamboo use the same user base. The second part is in the authentication, where only OAuth should be enabled and configured (not "Trusted Applications", not "Basic Access"). Then things looked to work properly.

Of course, as soon as I type that, I figured it out. In the application connection, on Outgoing Authentication, I had to configure it as a Trusted Application, so that it says this: ""Jira" (JIRA) is currently configured to make requests into "Atlassian Bamboo" (Bamboo) using Trusted Applications." Now it works as expected and lets me click through to Bamboo from a Jira ticket.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,308 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot