Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

gadget.common.error.500 using nginx and HTTPS Edited

Hello, I recently installed Jira 8.2.0 on a RHEL8 server and I'm with issues about gadgets on System Dashboard.

It appears to be an widespread problem:

https://community.atlassian.com/t5/Jira-Software-questions/gadget-common-error-500/qaq-p/1007783

https://community.atlassian.com/t5/Jira-Software-questions/Jira8-behind-Nginx-proxy-gadget-common-error-500/qaq-p/1010477

https://community.atlassian.com/t5/Jira-questions/Jira8-behind-Nginx-proxy-gadget-common-error-500/qaq-p/1050620

 

I gone through all those topics and tried everything, even mimicking configurations, but I wasn't able to solve this issue by myself.

So I'm here for help.

 

Here's my configurations:

/opt/atlassian/jira/conf/server.xml

        <Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"

                   maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"

                   maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"

                   acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="true" scheme="https"

                   proxyName="jira.domain.tld" proxyPort="443"/>

 

/etc/nginx/conf.d/jira.local.domain.tld.conf 

upstream jira {

server 127.0.0.1:8080 fail_timeout=0;

}




# redirect HTTP and handle let's encrypt requests

server {

listen       80;

listen       [::]:80;

server_name  jira.local.domain.tld

    jira.domain.tld

    www.jira.local.domain.tld

    www.jira.domain.tld;




# handle letsencrypt domain validation

location ~ /.well-known {

allow all;

}




# send everything else to HTTPS

location / {

return 301 https://jira.domain.tld;

}

}




# listen on HTTP2/SSL

server {

listen       443 ssl http2;

listen       [::]:443 ssl http2;

server_name  jira.domain.tld;

root         /opt/atlassian/jira;




# snakeoil certificates

ssl_certificate /etc/nginx/ssl/jira.crt;

ssl_certificate_key /etc/nginx/ssl/jira.key;




location / {

# allow uploads up to 10MB

client_max_body_size 10m;

# set proxy headers for cloudflare/jira

proxy_set_header  Host $host:$server_port;

proxy_set_header  X-Real-IP $remote_addr;

proxy_set_header  X-Forwarded-For $proxy_add_x_forwarded_for;

proxy_set_header  X-Forwarded-Proto $scheme;

# hand the request off to jira

proxy_pass        http://jira;

}

}

 

I tried adding the web certificates to the keystore located on /opt/atlassian/jira/jre/lib/security/cacerts and it doesn't solved the issue too.

ca, May 23, 2019, PrivateKeyEntry, 

Certificate fingerprint (SHA1): C2:49:32:92:BE:7F:C3:18:FB:C9:4E:22:86:F8:B8:19:E1:26:88:B4

jira, May 23, 2019, PrivateKeyEntry, 

Certificate fingerprint (SHA1): D2:DD:06:71:A1:9A:B3:5E:46:3B:8C:79:F7:A7:40:EA:F7:F2:4F:EA

 

And yes, my base URL is set to: https://jira.domain.tld.

 

Thanks for your help. 

4 answers

1 accepted

0 votes
Answer accepted

I solved this changing the JRE to the system JRE instead of the shipped JRE. Everything worked flawlessly after the change.

Hello Vinícius!

I did not understand the change you made. Do you have any step-by-step instructions?

Hi! I have exactly the same config and problem...

I have exactly the same config and problem.  Has anyone managed to solve it? I'm using F5 to avoid loading the certificate into the Jira application.

@Polybio FernandesDid the guide solve your problem? After upgrading I am having the same issue. :( Other than that, Jira does work flawless. Just having that gadget URL error.

Hello!

This may be because the update has replaced the "server.xml" file for the default settings.

Mine resolved as follows:

For SSH, enter the / opt / atlassian / jira / conf folder
# vi server.xml

1) Comment all jira configuration block DEFAULT:

2) Enable the HTTPS block settings as example remembering to enter the domain name of your certificate that is in F5 in the "proxy name".

=========================================================
HTTPS - Proxying Jira via Apache or Nginx over HTTPS

If you're proxying traffic to Jira over HTTPS, uncomment the below connector and comment out the others.
Ensure the proxyName and proxyPort are updated with the appropriate information if necessary as per the docs.

See the following for more information:

Apache - https://confluence.atlassian.com/x/PTT3MQ
nginx - https://confluence.atlassian.com/x/DAFmGQ
=========================================================-->

<Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"
maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"
maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"
acceptCount="100" disableUploadTimeout="true" bindOnInit="true" secure="true" scheme="https"
proxyName="jira.domain.com" proxyPort="443"/>
<!--

Like Dmitry likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you