dynamic-forms removed the default value I set for checkbox

A checkbox field has default values set for it. Looks OK on screen.

When setting a dynamic-select field to open this checkbox field, it opens without the default values I set. 

Any idea?

4 answers

Hi, Did you get any update on this? We also facing same issue. Thanks.

Hi If I recall, Intenso said it's a bug that will be fixed later on. Didn't checked that yet. I advise you to contact them.

Do either of you know if this was fixed?  I'm having a similar problem with a user picker field that gets displayed based on a dynamic select field.

This reply is not an answer but another documented case regarding the JIRA plugin inTENSO Dynamic Forms using the Dynamic Checkbox field. I seems similar to the original question as it involves data not being retained during the create issue function. In addition to this, we see that even if the checkbox field is set using the Edit screen, the data is not stored in the database as subsequent views of the field are NULL. We use the same screen for Edit and View functions. Specific details are below.

We are using the Dynamic Forms JIRA plugin and for one of our Custom Fields, which is a Dynamic Forms Checkboxes Custom Field, data which was entered into the checkbox field during the Create Issue Screen/Transition, is not visible using the Edit and View screen.

The Dynamic Checkbox field is used as a Related Required Field from a parent inTENSO Dynamic Select Custom Field option. While the checkbox field is displayed during the Create Issue Screen/Transition when the option is chosen in the parent Custom Field, and the Yes checkbox or the No checkbox is selected, this Yes or No selection is not being stored/seen when the issue is viewed. When attempts to Edit the field are made by selecting the Yes checkbox or the No checkbox, it appears to save the Yes or No choice as there is no error given. Then, when the issue is Viewed after the Edit/Update, the field is NULL, as both the Yes box and the No box are Null. So it really is not saving the choice made by the user.

If anyone knows of a documented fix, please let me know the resolution.

Thank you.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,316 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot