dynamic-forms removed the default value I set for checkbox

A checkbox field has default values set for it. Looks OK on screen.

When setting a dynamic-select field to open this checkbox field, it opens without the default values I set. 

Any idea?

4 answers

This widget could not be displayed.

Hi, Did you get any update on this? We also facing same issue. Thanks.

This widget could not be displayed.

Hi If I recall, Intenso said it's a bug that will be fixed later on. Didn't checked that yet. I advise you to contact them.

This widget could not be displayed.

Do either of you know if this was fixed?  I'm having a similar problem with a user picker field that gets displayed based on a dynamic select field.

This widget could not be displayed.

This reply is not an answer but another documented case regarding the JIRA plugin inTENSO Dynamic Forms using the Dynamic Checkbox field. I seems similar to the original question as it involves data not being retained during the create issue function. In addition to this, we see that even if the checkbox field is set using the Edit screen, the data is not stored in the database as subsequent views of the field are NULL. We use the same screen for Edit and View functions. Specific details are below.

We are using the Dynamic Forms JIRA plugin and for one of our Custom Fields, which is a Dynamic Forms Checkboxes Custom Field, data which was entered into the checkbox field during the Create Issue Screen/Transition, is not visible using the Edit and View screen.

The Dynamic Checkbox field is used as a Related Required Field from a parent inTENSO Dynamic Select Custom Field option. While the checkbox field is displayed during the Create Issue Screen/Transition when the option is chosen in the parent Custom Field, and the Yes checkbox or the No checkbox is selected, this Yes or No selection is not being stored/seen when the issue is viewed. When attempts to Edit the field are made by selecting the Yes checkbox or the No checkbox, it appears to save the Yes or No choice as there is no error given. Then, when the issue is Viewed after the Edit/Update, the field is NULL, as both the Yes box and the No box are Null. So it really is not saving the choice made by the user.

If anyone knows of a documented fix, please let me know the resolution.

Thank you.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

578 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you