c# SDK basic authentication stopped working

We created a API using the c# SDK to allow interaction between Jira and our internal time keeping system.  This has been working for months.

A Jira object is created using the CreateRestClient method:

private static Jira MyJira
{
get
{
if (_jira == null)
{
_jira = Jira.CreateRestClient(ConfigurationManager.AppSettings["JiraUrl"],
ConfigurationManager.AppSettings["userName"],
ConfigurationManager.AppSettings["passWord"]);

_jira.MaxIssuesPerRequest = int.MaxValue;
}

return _jira;
}
}

We use my account to run the API.  This morning I tried to login to Jira on the Web.  I was prompted to login.  I tried the username I normally use but was redirected to pick one of my google accounts to login.  I don't use google to login to Jira.  It would not log me in with my regular username.  The only way I could get in was to change my password.  If I logout and try to login I have to change my password again to get in.

I set my new password in the config file for our API but it does no authenticate. I tried going directly to the jira rest api using fiddler.  I created a new base64 auth string for my username:password and I get an authentication error.

Has there been a systems change that would explain this?

1 answer

1 votes
Sam Hall Community Champion Apr 22, 2017

Hi Mark - What version of JIRA are you using? JIRA Cloud or JIRA Server?

We are using Jira Cloud.

Sam Hall Community Champion Apr 24, 2017

One possiblity is that you have been upgraded to Atlassian Account.

That has some impact on the REST APIs as descibed here:

https://confluence.atlassian.com/cloud/the-upgrade-to-atlassian-account-873871204.html#TheupgradetoAtlassianaccount-RESTAPIs

"After the upgrade, REST APIs that accept Atlassian account user credentials expect a verified email address instead of a username."

I put my email address in for the username but it is still not authenticating.  My account seems to be broken.  If I logout of Jira the only way I can get back in is to reset my password.

Can my account be put back the way it was?  Can it be reset.  I need a solution we are not able to get our project information from Jira for time entry.  This a big problem.

What would be the quickest way to get me back up and running?

Thanks

Sam Hall Community Champion Apr 24, 2017

It could be a couple of things:

1. There is a current incident with Altassian Account login, which might be confusing things: https://atlassian.statuspage.io/incidents/01r8249rwb6r Wait for that to be resolved before trying again.

2. There have been some recent reports of problems with logins for some people that were recently migrated to Atlassian Account. See this thread: https://community.atlassian.com/t5/Questions/Can-t-login-into-our-JIRA-account-is-not-associated-with-any/qaq-p/579848

Your best bet would be to raise a support request with Atlassian and they should be able to help diagnose and resolve your issue. Do this at: https://support.atlassian.com/contact/

If you have problems accessing that link, you can try: https://www.atlassian.com/company/contact/general-inquiries

Sam Hall Community Champion Apr 24, 2017

By the way, I'm assuming you are (or have contacted) the admin of your Cloud instance.

if not, you should ask them for help and they can raise the support ticket on your behalf.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,861 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot