It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

automatic hyperlinking in JSD comments are never correct.

EVERY TIME we paste or type an email address into a JSD reply / comment (or anywhere in Jira or Confluence) the automatic hyperlink feature erroneously includes the PREVIOUS word in the link.  It's crazy.

Example. If I type this into the visual editor of a comment/reply:

email to sample@mydomain.com

As soon as I hit (space) or (enter) after that domain, the hyperlink created includes the "to " before it. Switching to text view reveals that the hyperlink feature resolved as this: 

email [to sample@mydomain.com|mailto:to%C2%A0sample@mydomain.com]

This has happened for myself and my team since we started using Jira, JSD and confluence years ago and we are forced to manually correct it every time. We just figured it was so bad that someone would have complained and it would be fixed in some update.  Alas, years later, nothing.

Any thoughts as to why this is failing? It is 100% reliably repeatable.

Thanks!

1 answer

0 votes
Andy Heinzer Atlassian Team Oct 03, 2019

Hi Chris,

Sorry to hear about this problem.  It seems like it has been a very big annoyance to deal with.  I have been trying to replicate the behavior you are describing here, however so far I have not had any success in doing so.

I have been trying to recreate this problem in both Jira Cloud as well as Jira Server 8.4.1.  I have been trying both with Chrome as well as the latest Firefox version.  In my testing I haven't been able to get the automatic mailto linking to see this space character as this

%C2%A0

character that seems to be getting inserted into your session somehow.  I found that character does appear to be a space according to https://www.w3schools.com/tags/ref_urlencode.asp but it's not clear to me yet why this encoded character would be getting inserted into this link yet.

I would like to learn more about this problem so that we can try to help here. 

  1. Could you let us know more about what Atlassian platform you are using here? (Jira Cloud or Jira Server)
  2. Also if this is server, I would be interested to learn what version of Jira you have here
  3. Tell us more about your environment, such as your client operating system, browser, versions, etc.
  4. I'm wondering if perhaps this is a language locale problem where this space character is being treated differently in some way.  I'd be interested to learn more about your system input settings in regards to regional locale.  In both Windows and Mac OSX there are settings in the control panel and system preferences that govern your keyboard input.   I'd be interested to see what settings you have here.

If this was only happening via a copy/paste, then I would really suspicious of the source data.  But since it sounds like you can do this just by typing this out, I'm thinking there is something funky going on with the way your system/browser is inputting that data into Jira.  If this is a Jira Cloud site, then I would certainly want to create a support case to investigate that way.

If this is a Jira Server instance, then well your licensing level might determine if that is an option or if we can only provide support here in Community.  Either way, I want to learn more about this problem.

I also tried to search for this problem in other support cases and through our public bug tracker jira.atlassian.com however I found no other reported incidents yet that appear to match this problem description.

Curious to learn more,

Andy

Hi Andy,

Yeah, I'm using a lame license so Community is all there is for me. It's part of the reason I waited so long to report something just sort of irritating, but not critical. I'm, so grateful to have Jira, that we usually stay kind of quiet about this level of trouble.

Here's the information you asked about. 

JIRA Server
-JIRA version 7.13.0 (an update is happening soon)
-Chrome, Windows OS
-Language setting is English (United States)We are a decentralized work force.

There is no commonality between the way our systems are setup other than Windows 10 defaults for us bland, U.S. people. We work from several different cities and do have a staff working in EU and we all have the same experience.

To confirm, I was suspicious about copy/paste as well, as I know that can cause problems. And it doesn't seem to happen with URLs. 

And now while I'm trying to make a video of it happening, I can't get it to fail. :) It was repeatably reliable for years, and now that I need it to do what it's been doing, I can't.  lol. Figures.

I'll try to get a failure on video and include it but it may now be gone. You may choose to stand down. lol

Thanks!

Andy Heinzer Atlassian Team Oct 10, 2019

Hi Chris,

Thanks for this info. I can feel the frustration here. It sounds very irritating. I will try to see if I can reproduce this on a Windows 10 environment.  If you are copying this from a specific document, I'd like to take a closer look at the document itself if possible.   If this was happening when you were typing it out manually, then I'd be more concerned about the regional input settings.

Basically I want to try to narrow the focus here any which way we can to be able to repeat this problem.  Once we can do that, then I can try to better isolate some factors. 

Hi Andy,

For sure... and I want to help also. And if it didn't just magically stop, then when I see it again, I'll try to get a screen video of it and any more details I can. Like I mentioned this has been the way Jira has worked for us since way in the beginning. Of course, years later, the moment we surrender to burdening someone for help, we can't make it happen.

When (if) it happens again, I'll report it to you. Sorry... ugh

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

The add-in you’ve been waiting for: Jira Cloud for Excel 🙌

Introducing Jira Cloud for Excel Here at the product integrations team at Atlassian, we are thrilled to announce the new Jira Cloud for Excel add-in! This add-in lets you export Jira data directly ...

841 views 5 22
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you