Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage
  • Community
  • Products
  • Jira
  • Questions
  • Why not getting the SAVE option when changing one of my existing filters. Only can SAVE AS. Happens in CHROME & IE. WHY?

Why not getting the SAVE option when changing one of my existing filters. Only can SAVE AS. Happens in CHROME & IE. WHY?

Using CHROME or IE, can't SAVE one of MY existing filters even after I run the filter, user still can't just SAVE the filter. Can only SAVE AS. Seems to be isolated to only one User that I am aware of. Also tried it in IE and it didn't work there either. User has logged off and even rebooted without success.

 

Using Chrome: v31.0.1650.57 and java 6 update 45(build 1.6.0_45-b06)

JIRA 6.2.4 (Server version)

 

7 answers

2 accepted

You will have to make the changes and run it before you can save it. Make your changes and click on the Search button before trying to save.

We did that already and it still will only allow you to SAVE AS.

Like velizar_v likes this

It should be a bug then. Are you sure the filter is owned by the user?

Yep same, this is a bug for sure

Also it's really annoying because it then won't even allow you to 'save as' over the top of the existing filter, which in itself is a separate bug

it is a Bug, however there is a workaround, the save button shows momentarily once one updates the existing filter and hits the search (lens) icon. If you are quick you should be able to hit the save button and observe a bubble message "The filter ****** has been successfully saved" 

Same here. I can create a query, save it, then am not allowed to modify it and save again.

Told a lie. After changing something in the filter and running you do indeed get 'save'.

It seems to be unclear what Jira considers a 'change.' If you change the displayed columns for the filter, that evidently is not a 'change'

Like Jeff Abbott likes this

It seems column changes made by the owner are automatically saved to the filter IF you have columns set to "Filter" instead of "My Defaults" or "System".

1 vote
Answer accepted

The same thing was happening to me and I found a solution that worked. If you make the change and see "Save As" you can go to the ... in the top right corner. If you open it up, it should say "Clear Sorts" which I did. The "Save" option came up for me

I had the same issue but found a workaround.  I had to change the original JQL and hit Search for the Save button to display.  I changed the JQL to something I did not care about and then saved it.  I then changed the JQL back to what I wanted, hit Search and was able to Save.

As a workaround, once you make the required changes in the query and click on 'Search' button, and once the results load, click on refresh button in the browser. You will be able to see the 'Save' button.

Tried this in chrome and it works.

Thank you, it worked for me too. 

thank you!!

this works

I have the exact same problem. Any solution for this? I am the owner of the filter but every time I make any modifications it makes me to save it as a new filter and this creates many version of my filters which is an unnecessary duplication. 

Filters have owners as well; By default JIRA sets the owner to the one who created the filter.

Go to Shared filters, find the one to which you're trying to edit the query then click settings icon and select change owner. User should be able to update the query.

Unfortunately, filters can have only one User.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you