Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,899
Community Members
 
Community Events
176
Community Groups

Why does JQL "timespent = > 3h" not return tickets in Service Desk project?

I am trying to fix a queue to find service desk tickets that have more than 3h logged against them. There are many of these in the project, so results should be returned, but the filter returns no results. The same thing happens if I try to do this in Advanced search:

project = SD AND timespent >= 3h

That filter returns all other tickets that are over 3h for other projects if you remove the project filter, so it is the correct format.

I have all admin permissions and access required in Tempo and in the project, so I'm definitely able to view this data. 

This queue used to work - has "timespent" been deprecated for SD type projects?

2 answers

1 vote
Tom Lister Community Leader Dec 15, 2022

Hi @Patrick Alexander 

I have tested this with JSM and non-JSM projects and it works in my system.

Screenshot 2022-12-15 at 11.06.37.png

This may be related to Tempo settings. I found during a cloud migration this year, that the cloud tempo permissions are much more specific. I would double check your team/project perms on the service desk.

Hi Catherine,

i tested the behaviour in our system and it also doesn't work.

What i get is a working querry when only givinng a number to it. So for example:

project = SD AND timespent >= 3

In this case it will count on 3 minutes. So maby as a workaround you can try this wirh 180?

Greetings

Thanks for this but I've tried it and it still doesn't do anything! This is so frustrating.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events