Webhooks not triggered

We use JIRA v7.0.10.
The webhook, event driven, works fine when you click on the URL (HTTPS) in the webhook configuration GUI,
But not fired when an issue is updated.
There are no information about this in the catalina.log file.

What is the problem? 

11 answers

This widget could not be displayed.
Steven Behnke Community Champion Feb 13, 2016

Can you talk about the webhook you've set up, like what even is it on and what condition it occurs under? Can you also tail the application log in [JIRA-Home]/log/atlassian-jira.log for additional information?

This widget could not be displayed.

Issue related events
JQL: All issues
Issue: updated
Exclude body: No
Transitions:  No linked transitions.

atlassian-jira.log:
...

2016-02-10 01:30:00,732 Caesium-1-2 INFO anonymous Backup Service [c.a.j.bc.dataimport.DefaultExportService] Data export completed in 569ms. Wrote 2498 entities to export in memory.
2016-02-10 01:30:00,734 Caesium-1-2 INFO anonymous Backup Service [c.a.j.bc.dataimport.DefaultExportService] Attempting to save the Active Objects Backup
2016-02-10 01:30:01,575 Caesium-1-2 INFO anonymous Backup Service [c.a.j.bc.dataimport.DefaultExportService] Finished saving the Active Objects Backup
2016-02-10 10:42:00,004 Sending mailitem com.atlassian.jira.mail.IssueMailQueueItem@225fdcb[issue=com.atlassian.jira.issue.IssueImpl@3c758e61[id=10267,summary=Test2.,key=EIT-87,created=2016-01-28 13:38:04.0,updated=2016-02-10 10:41:06.0,assignee=user(NN),reporter=jirarest(jirarest)],remoteUser=admin(admin),notificationType=Current_Assignee,eventTypeId=3,templateId=3] WARN anonymous Mail Queue Service [c.a.jira.mail.IssueMailQueueItem] There is no default SMTP Mail server so mail cannot be sent
...

This widget could not be displayed.

I am seeing exactly the same issue.  Is there a solution / workaround?  The endpoint URL is not called.  We created a ticket and also updated it, but Webhooks did not fire on create or update.

This widget could not be displayed.

Seeing the same issue as of 2/15/2016. WebHook was working fine, but now won't fire/trigger on create, update, or close. Please help!

This widget could not be displayed.

Same is happening with us. I found a couple articles that seemed to suggest that it might either have to do with a port being specified in the url of the webhook or that the webhook is going to apache that is on the same host using the same hostname. We have tried changing both and still no luck.

This widget could not be displayed.

To Steven B:
Can you please give us a status update of the issue!

This widget could not be displayed.
Steven Behnke Community Champion Feb 21, 2016

Maybe I can expand on this in the morning but I have nothing to offer but troubleshooting steps for now. One user posted some portion of their log but they didn't include any bit detailing why their Web hooks didn't fire. It's essential to find the log or logging component necessary to see what the Web hooks module is doing. The application allows you to increase logging, so if you can't find any issues in the log you may need to increase the logging levels. 

If you are uncomfortable with this you *need* to open a support issue with Atlassian to trace down support related issues, Atlassian answers is a user forum and I just have some interest in the products. :) 

Unfortunately these issues are also susceptible to their environment so Amy changes to your os, host, network, proxy, etc on your server or your client could be at fault. 

This widget could not be displayed.

Ours seem to be functioning as of this morning. Around 11am MST (on 2/22/2016). I have closed out my support ticket.

Thank you!

This widget could not be displayed.
Steven Behnke Community Champion Feb 22, 2016

I don't see any open bugs which means we need to troubleshoot. Please follow up with https://support.atlassian.com or provide logging of webhook success, fails, or other information.

This widget could not be displayed.
Steven Behnke Community Champion Feb 22, 2016

Good luck Ryan!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

195 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you