Webhook POST messages have an empty body

Hi,

I have an OnDemand Jira account and I am trying to use the webhooks functionality on it. Problem is that it does not seem to work properly. POST messages are sent to my URL, but they are being sent with an empty body. The "Exclude details" option from my webhook config is unchecked so the problem doesn't seem to be configuration related.

The strange thing is that even if the body of the message is empty, the Content-Legth header is different from 0 (usually above 3000). If I go to the webhook configuration and check the "Exclude details" option, messages will come with an empty body (as they should) and also with "Content-Length: 0".

Does anybody have any idea what might trigger the problem and how can I make the webhooks properly include details in the body of the POST message?

Best regards

1 answer

1 accepted

It turned out that the problem was not related to the Jira web hooks engine, but rather by some network related problems in the LAN of the machine that was hosting my webhooks client.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,110 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot