Using a reverse proxy with Jira: mismatched URL Port

Hi everybody smile

I've got a question regarding the combination JIRA & reverse proxy.

We are using nginx as reverse proxy - as far as I can see everything is working fine but on the login-page a message is displayed by jira:

warning.png

 

 

Since the the three links ("Gadgets do not..", "Integrating JIRA with Apache" "Integrating JIRA with Apache using SSL") did not seem to solve the issue in my case, I went to "System" - "Atlassian Supporttools" and started Hercules. Hercules reported an error:

Unable to View Dashboard 'UrlPortMismatchException' Due to Apache Tomcat Connector

and offered this solution: https://confluence.atlassian.com/display/JIRAKB/Unable+to+View+Dashboard+%27UrlPortMismatchException%27+Due+to+Apache+Tomcat+Connector?utm_source=STP&utm_medium=logScan

As per description I added proxyName and proxyPort to to Connector-Tag in /opt/atlassian/jira/conf/server.xml and restarted (just to be sure wink) the whole server. Unfortunately this did not solve the problem.

I found out that I can close the message on the login-page so that the message is no longer displayed but this will not really solve the issue, right? wink Additionaly even if the message is hidden there is still a white placeholder or something which causes that the "Meinen Login auf diesem Computer speichern"-Message (~ remind my login) is not shown properly (only about 20% of the text is visible, I think this might be an css-issue) - please have a look at the attached screenshot:

shot1.png

How can I tell JIRA to ignore the mismatched URL port?

 

Kind regards,

Dirk

2 answers

1 accepted

This widget could not be displayed.

Hi Jobin, thank you for your reply smile

I cleared the cache but it didn't work. I'm not sure if my server.xml is correct. Just to be sure please find attached the part of my /opt/atlassian/jira/conf/server.xml where I added proxyName and proxyPort:

...
<Service name="Catalina">
  <Connector acceptCount="100" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" maxHttpHeaderSize="8192" maxThreads="150" minSpareThreads="25" port="8080" protocol="HTTP/1.1" redirectPort="8443" useBodyEncodingForURI="true" proxyName="myserver.mydomain.de" proxyPort="443" />
...

I guess proxyPort="443" is correct, since the message on the login-screen is "JIRA is reporting that it is running on the port '8443', which does not match the hostname used to run these diagnostics, '443'", right?

As base-url entry under Administration > Genral Configuration I entered https://myserver.mydomain.de:443

Yes, 443 is correct. And when you have 443 as the port, you don't need to add it in URL. Your base URL can be https://myserver.mydomain.de. So, what is the issue you are facing now? Did you try it in different browsers?

Thank you, the issue regarding the Dashboard-diagnostics message is now solved. The only problem I now have is that in some browsers the login-box is not shown properly- shall I open a new topic for that? :-)

I'm sorry but I'm afraid my comment from Feb. 16 was premature - the message "We've detected a potential problem.." (as mentioned at top in my posting from Jan. 21) is still displayed on the login page: https://helpdesk.companyname.de The base-url (Settings - General Configuration) ist set to https://helpdesk.companyname.de I have no idea how to solve this - is there a way to hide the message for normal users?

Update: upgraded to Jira V6.4 and added proxyPort to server.xml. After that I restarted the server and - just to be sure - I cleaned the browser cache. It seems that the problem is solved now. Yay! :)

This widget could not be displayed.

That issue should be resolved once you add the proxyName and proxyPort. I would try clearing the browser cache and logging in again.

Once you are logged in, make sure the base URL is setup correctly under Administration > General Configuration.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

179 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you