User seems to not have any permissions

I setup a user an made sure he has permissions to browse the project issues:

1.He is part of a group that I added in the permission scheme asocciated with the project in question

2.He has the project roles: User & Developer

when I try to login with the user account, I get an empty Dashboard page with the message:

"This dashboard does not contain any gadgets or you do not have permission to view them. Perhaps you need to log in to see them."

I used the permission helper for the user and here everything seems to be fine:

Group XYZ is in the extern group

Project Role XYZ is a member of these project roles: Developers, Users

4 answers

1 accepted

finally found out what was amiss: my group was not added to the jira users in the global permissions page.

Mick Nassette had the answere:

Mick Nassette [Atlassian] added a comment - 20/Mar/13 11:06 AM

Hi Oliver,
There are 2 ways to accomplish this. First of all, you can define user permissions though the permission schemes tied to the specific project. Often, the permissions are assigned based on project role. You can assign individual users or user groups to project roles.

Currently, it is likely that any newly created users, are receiving permissions in different projects due to the fact that the group "users" has been assigned to project roles in these projects.

Therefor, one solution would be to remove this group (or any other relevant groups to this user/project) from the project roles in the projects where the specific user is not supposed to have access to. Essentially, you will only have to apply this to the "Browse Projects" permission, since this locks out any other actions. This solution however requires you to go through all your projects in order to get them properly configured. Though this can be a lot of work, when your instance is growing and is getting more and more projects and users, this solution scales best in such a scenario. So though it might be more work now, it might save for in the future.

The second solution would be as follows: Create the user. Create a group. Add the user to the newly created group and remove it from all other groups. Add the group to the JIRA Users permission under your global permissions. Configure the permission scheme of the relevant project according to your wishes. Opposed to the first solution, this requires less work to set up for 1 or a few projects, but it scales badly when your instance grows. It will especially become rather hard to configure and maintain when you are getting users which require overlapping permissions in various projects.

I hope either of the 2 provided solutions are to your requirements, if you need additional assistance, please let me know.
Cheers,
Mick

HI Oliver,

This error seem to be related to the permission over the system dashboard. Please check in Administration -> User Interface -> System Dashboard. You can also create a new dashboard and attribute to the user. The following pages wil explain you more about this:

- https://confluence.atlassian.com/display/JIRA/Customising+the+Dashboard

- https://confluence.atlassian.com/display/JIRA/Managing+Multiple+Dashboard+Pages

Best regards,
Lucas Timm

Hi Lucas,

thanks for your answer. I tried to acces an issue directly for which the permission helper told be my user should have access rights but that didn't work either.

then I removed everything from the system default dashboard (just to make sure there is no content for which my user does not have access) but still no luck.

I'm beginning to doubt the sense of the permission helper if it clearly does not match the reality.

0 vote

Hi Oliver,

Can you also confirm that the user is part of the users group or a group that has JIRA Users Global Permission? If not, he will not be able to login to the system as that permission is required to use JIRA.

Best,

-dave

the user is NOT part of the "users group"

everyone in this group seems to have the right to view all projects in the default permission settings.

however, I have another user that is not part of the users group and for that user everything is working as expected.

I tried to find the "JIRA Users Global Permission" you were talking about but couldn't find it anywhere.

the only kind of permissions I can manage in a permission scheme are:

Project Permissions

Issue Permissions

Voters & Watchers Permissions

Comments Permissions

Attachement Permissions

Time Tracking Permissions

You may be looking at the wrong dashboard. Is he seeing the System Dashboard or another dashboard which the user has set as the favorite? (If there is only one dashboard which the user has set as favorite, there will not be any dashboard switcher to the side).

And please check the dashboard permissions of that one as well as the filters used in the dashboard.

(A screenshot of the issue will help to understand what is going on)

this is the login screen for the user

this is what I get when I login

those are my dashboards

here I tried to make sure that no dashboards are private:

part of the permission scheme for my user/project

here how I associated the permission scheme with the group

my user:

this I get when I view the roles of the user:

...which I seemingly cannot change anymore?? this is definitly a bug.

@Renjith did the screenshot help?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

132 views 0 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you