Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to view remote issue links using new Jira issue view

We use a 3rd-party application to create remote issue links in a Jira instance using the Jira REST API.  Using the old view, we are able to see the remote issue links under the Linked Issues section, but we do not see them under the analogous section (Issue Links) when using the new issue view (https://confluence.atlassian.com/jiracorecloud/the-new-jira-issue-view-938040503.html).  The creation of the remote issue link is logged as History under the Activity section; we can see this using the new view; just not the remote link itself.

2 answers

1 accepted

2 votes
Answer accepted

Hi Cory,

This issue that you are facing where you can't see the links on the new issue view is a bug:
- https://jira.atlassian.com/browse/JRACLOUD-69016
This happens for links to articles, websites, documents and other types of links.
Please, click on vote and watch to receive updates about the bug.

I have also added the link of this question on the bug so that the developers can reference it if necessary.

Regards,
Angélica

Thank you for the detailed response, Angélica.  As you suggested, I have clicked on vote and watch.

I see that this has been a known issue since March.  Besides through automated emails from changes to the bug, is there any way of knowing when this might be fixed?

Hi Cory,

We still don't know when this bug will be fixed.
For your reference, you can find our policy on how we prioritize bug fixes here.

Regards,
Angélica

Angélica, thank you for your help.  It's much appreciated.

You are always welcome Cory!
If you have any other question, please let us know.

Regards,
Angélica

@Angélica Luz We're having similar issues.   I use the API (https://developer.atlassian.com/server/jira/platform/creating-remote-issue-links/) to create remote issue links.

The next-gen view does not show these links but the old view does.

I looked at the bug linked above and it seems to be different. 

Is there an update to this remote issue links not showing in new view bug?

Thanks.

@Angélica Luz you suggested looking at and voting on JRACLOUD-69016. This is an issue, but not exactly what @Cory Gibson is experiencing. I believe he is experiencing what I am. For instance, I attached a link to a Trello card. In the old view, this shows up under links, but in the new view it is no where to be found (other than the history). Do you have plans to show non-Jira/non-Confluence links in the future? Is there a bug or feature request for that?

@Judah Ferst , I have since been made aware of the issue that more represents the problem we're experiencing: https://jira.atlassian.com/browse/JRACLOUD-70211.  This one is also related: https://jira.atlassian.com/browse/JRACLOUD-69973

Thanks - I just voted on this. Some response about things that you used to be able to do but can not do anymore would be really helpful @Angélica Luz 

0 votes

Hi David,

The bug is that the linked issue does not show as a link in the comment. We have another bug reported related to that, where it shows a link but not the status:
- https://jira.atlassian.com/browse/JRACLOUD-69230
I see that the documentation that you shared is related to Jira Server, can you test using the API from Cloud?
- Create issue link

If what happens on your instance is different, please share a screenshot with us, so we can try to replicate the issue here.

Regards,
Angélica

Apologies for dragging this up on an old thread but I'm at a loss with how to resolve this issue, we are finding similar behaviour when creating remote links via the API.

The history shows that the link was added to RemoteIssueLinks but no link shows.

I have added full details here

Hi @Sam Peerless ,

I recently tested the advice given at https://jira.atlassian.com/browse/JRACLOUD-74599?focusedCommentId=2662178&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-2662178.  We include the "application.type" value in the API request, but after removing it, we can see the remote issue link in the new issue view.  As stated in that issue, the link's summary isn't displayed, but at least the link's title is displayed and has the working URL.

Like Sam Peerless likes this

Hey @Cory Gibson 

Works a treat! That is perfect thank you, a major headache solved for us there! 

Like Cory Gibson likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you