Unable to find newly created custom fields in custom field list

I created 3 new custom fields, simple Select List (Single Choice) fields with four options.

When I go to the list of custom fields, it does not display the new fields in the list.

However, going to audit logs shows my ID having created the field, as well as screens allows me to add those fields to a screen. 

The problem is, I need to add additional options to the list, and I am not able to do that, since the field itself is not visible for me to edit it (from the Custom Fields view page). Other fields created in the past are available however, and I am not sure what is causing the newly created custom fields to not show up.

2 answers

0 vote
Joe Pitt Community Champion Jan 05, 2017

Try re-indexing. If that doesn't work I'd open an issue with Atlassian. 

Tried that, no dice. Issue persists.

0 vote

What happens if you try to re-add them?

Same issue. Not visible on the list.

Question - you tagged this with Service Desk - are you really looking at a portal, or are you looking at plain JIRA's list of custom fields? 

I tagged it as Service Desk because that's the version of JIRA we're using. We migrated from JIRA Server to Service Desk a few months ago. Most issues have popped up since then.

And within our version - I am looking JIRA's list of custom fields. Newly created custom fields just don't show up on that list. They're functional otherwise, but you're stuck if you need to edit them.

Hmm.  There's one thing I can thing of that causes them to vanish from the list.

Is the list cut-off, rather than missing items?  If, for example you have custom fields named A, B, C, D, E, F, G, and C and D are new ones, does the list show ABEFG, or just AB?

In the above example, it shows ABEFG. 

The list is sorted alphabetical, the custom field is named "Test Plan Type".

I'm seeing fields starting with Y (that were created earlier), but Test Plan Type does not show up on the list. 

Ok, that rules out that idea, but leaves another one open.

What type are the new fields you've added?  And if you add a simple select list (with a plain name like "temporary field", and no description, defaults or options), does that appear ok?

No, it is a simple select list field with the name "Test Plan Type" and has 4 Options to choose from.

No descriptions or defaults added.

I'll a try a simple select list without adding options and report results.

UPDATE - Configuring a select list (single choice) needs atleast 1 Option to be set to create the field. Wont create the field otherwise.

Don't worry about the option, the important bits were a plain field and no attempts to be clever with descriptions or defaults.

Understood. It was a simple field - no bells and whistles. 

Ok, does the new test field show?

No it does not. sad We've tried everything, have an open ticket to Atlassian, sent them support zip to see if they can find something.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,305 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot