The values in select list custom field are not listed as a drop down and unable to select values

Created a custom field of type select list and added various options to it. But when displayed in the issue creation screen it is not seen as a drop down list; the values are not active and does not allow selection.

4 answers

0 vote

You'll need to give a lot more detail here. We have no idea how you "added various options", what you've done with the view, how you've configured it or anything else. It's not even clear whether this is a standard field, or one you've written yourself. Even "the values are not active" is not very helpful in describing what is wrong.

Could you tell us exactly what you have done?

The Jira version we use is 4.0.1; The added custom field type is 'Select List', which is a standard one. The various options were configured through 'Edit Options' function.

Not sure what could have gone wrong and why the values are not active?

Ok, what does "not active" mean? Do they not appear in the list at all?

Having asked that, I actually suspect you've got the "context" wrong. You can define a select list, with several possible sets of options, and say "use set 1 for project A, set 2 for project B, set 3 for project C" and so-on. My guess is that you've defined "set 1 for project A" and are expecting it to appear in project B? Go to the list of options and look at the top where it should say "this context is for projects..."

Some screen shots etc at https://confluence.atlassian.com/display/JIRA/Configuring+a+Custom+Field

'Not Active' - I meant, unable to select a value

There's only one context, which is default and only one project in this instance.

I'm sorry, but "unable to select a value" is still not quite descriptive enough. Why can't you select a value? Is the list populated? Greyed out and unclickable? Select something and it doesn't save?

Yes. Can't select a value; List gets populated but greyed out and unclickable.

Can we ask what was wrong in the end? Some javascript you'd been messing with? A plugin?

No ideas; I re-installed the instance and restored the same xml, where it worked fine.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

689 views 6 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you