It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Table inside JIRA issues creates broken column Edited

Hello everyone, 

since using JIRA we used a table as layout for our CCM to give precise information. They created the issue with the following example code below. Since some weeks this creation of tables seems to be broken, because it adds a third column with broken format to a two column table. The table code is copied from this JIRA documentation: https://jira.atlassian.com/secure/WikiRendererHelpAction.jspa?section=tables

They example in the documentation is not working properly as well. Any idea how we can fix this? 

 

Table layout we are using (sorry I don't know how to post a code block here :/):

||Type||Data||
|Point 1|XXX|
|Point 2|XXX|
|Point 3|XXX|
|Description|XXX|

 

1 answer

its is because of the space between two lines.

remove the space ( Press the delete key in the last position ( next to pipe symbol) and once it come to single line,press Shift+Enter 

||Type||Data||
|Point 1|XXX|
|Point 2|XXX|
|Point 3|XXX|
|Description|XXX|

Hey, 

the formatting in my post was broken, thanks for that. We don't have any line breaks between the lines - I tried your code as well but it creates an unnecessary, broken column :/ Any other ideas?

Hey,

Can send us the screenshot, how the renderred table look like?

Is the issue coming all JIRA fields like Description, Comments and Custom fields?

post that

1) Try reindexing JIRA once

2) Make sure the rendering is setup as mentioned here
https://confluence.atlassian.com/adminjiraserver073/configuring-renderers-861253418.html

html module should be disabled in Wiki Renderer Macros Plugin

 BTW
Indexing and Configuring renderers
also possible only by your JIRA Administrators global permission.

Hello,

 

thanks for answering so quick!

Below a screenshot of how the table looks. 

image.png

We only use the table within the description field, therefore we never tried it in another field. I am not sure how it behaves there. 

 

The description field uses the wiki-style renderer, but I cannot find how to see wether the html module is activated or not. Could you explain this in more detail?

Hello @Balavinayagamoor Ramasamy 

do you have any idea about the issue? Is there something we can test? 

hello Phillip,

I have few more questions.

1) is the reindexing done?

2) did you check setup as mentioned here ( 7 out of 8 Modules)
https://confluence.atlassian.com/adminjiraserver073/configuring-renderers-861253418.html

html module should be disabled in Wiki Renderer Macros Plugin

3) is this issue coming in all the issue description or

only in the particular issue?

if it is coming only in particular issue, the other texts in the same field may disturb the table rendering..

4) is the issue coming when a new table created from template?

image.png

  

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you