Slow performance after upgrade to jira 6.1

Hi All

I recently upgraded to jira 6.1.4 and after the upgrade i find that the performance of the system has slowed down a lot.

The slowness i observe is in doing general things, like clicking on administration buttons, clicking create issue buttons, transitioning issues, logging in.

I currently have 1.5 GB of RAM alloted to the JIRA install; I have Windows 2008 server installed on a 4GB VM with jira installed as a service; connected to Mysql database on another system. Only JIRA is running on the VM.

Is there any way to improve the performance of the system? Throwing in more RAM?

Note : this I am observing on my test instance when there is no users logged in; i would imagine the performance to be lot more slower on production when hundreds of users will be logged in at any time.

5 answers

This widget could not be displayed.

Which version did you use before the upgrade?

This widget could not be displayed.

@michael: from 5.0.2 jira

This widget could not be displayed.

Hi Rahul,

Could you please describe in detail how did you upgrade your JIRA instance. May I know if there are any changes of JDK, for example from 1.6 to 1.7 or 32bit version to 64bit version.

One of the issue might be due to JDK version. If it is 64bit it is necessary for you to increase the memory allocation to Xms at least 2GB due to the nature of how 64bit allocated its memory.

Another issue might be due to the JVM parameter does not brough over during the upgrade process which mean JIRA memory allocation is back to default, which may not be enough for your instance.

Hope it help.

Cheers,
Septa Cahyadiputra

Hi Septa

We have jira standalone installed on windows server. So i assume latest version of JDK is automatically installed from the installer.

Ours is a 64 bit install.

Yes, i have updated the JVM parameters, it is

MaxPermSize=384MB

Initial memory pool= 512 MB

Max memory pool = 2048 MB

Are my configurations right?

What other factors can be involved in the slow performacne?

Thanks in advance,

Rahul

This widget could not be displayed.

we've got the same problem.

We performed an update from 5.2 to 6.1.x and after that the users spoke very unfriendly about the systems performance

We updated the 5.2 via installer, the database is a ms sql, the linux runs on a vm and has 16GB mem, Jira is configured with 4GB/8GB/768MB min/max/permGen We use the JVM that comes with the jira. There are no other applications running on this server.

Actually we monitor the System with a munin but we can't see any problems.

It is a bigger licence: 2000 People.

This widget could not be displayed.

Hi Rahul,

we had exactly the same problem! We also had the problem, that users couldn't create issues under background-indexing...

I've raised a support request and after 2 weeks of investigation Atlassian found out, that there is a huge performance-bug in Jira 6.1 which was fixed for AOD and for download-version 6.2.

Here the Bugs:

https://jira.atlassian.com/browse/JRA-36179
https://jira.atlassian.com/browse/JRA-35356

we updated to 6.2.X and Jira runs as always :-)

Kind regards
André

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Friday in Jira

New 5k User Limit and Other Cloud Updates

Hi all! Lauren here from the Enterprise Cloud marketing team.  I have some exciting Cloud updates from #AtlassianSummit that I wanted to share. We want everyone in your organization to be ab...

121 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you