Service desk not installed? Edited

Hello Community and Atlassian Support,

I am experiencing an issue that JIRA shows Service Desk is not installed on the Configuration -> Application page.

in the meantime I used the Log Analyzer and tried some things which could have solved the problem but it didn't:

 

It would be nice if anybody could help. The main question is: how can I show some logs except copying a long chain into this topic?

I hope this is not because

'com.atlassian.labs.hipchat.hipchat-for-jira-plugin' - 'HipChat for JIRA'  failed to load.

is shown in the logs, don't want this plugin and it was long time working after I uninstalled it.

 

 

PS: it is very bad that support for starter licenses has been stopped. I used the "send Help request" function before....entered my long text asking for help and got a case closed answer (JSP-391103)

5 answers

1 accepted

I could solve the problem myself now:

the problem was that some com.atlassian.servidesk.XXXXXX plugins were - however - not enabled. After re-enabling them via SQL command I restarted JIRA and the JIRA SD application was started and visible in Manage > Applications

pluginstate.png

What table is this?

0 votes

>deleting jira-servicedesk-application-X.X.X.jar

Argh!  Why are you messing around with the file system? 

First, you should shut down JIRA and undo all the damage you have done to the installation.  Put it back the way you found it.

Second, restart it.  I would also re-index at this point, but you could leave that until last if you want.

Third, log in as an admin, go to Application management and add Service Desk from there.

Hi Nic, thx for your answer.

Well it was because the Atlassian help said it:

JIRA Service Desk Fails to Start with a Timeout error after its Installation

to your mentioned points:

  1. did not try yet but can restore it from backup
  2. done
  3. that's what I tried first, "reinstall" while it says it is not installed

I restored the JIRA program folder from backup now but I think my little mistake was that it will be repaired through an update from 7.4.0 to 7.4.1

EDIT: I could find out that this entries are written in the log.

2017-07-27 08:26:06,326 http-nio-8081-exec-13 INFO woestmar 506x2087x1 1mfuc4h 192.168.1.100,0:0:0:0:0:0:0:1 /rest/plugins/1.0/com.atlassian.servicedesk.internal-base-plugin-key [c.a.plugin.manager.DefaultPluginManager] Found dependent enabled plugins for plugins '[com.atlassian.servicedesk.internal-base-plugin]': [com.atlassian.jira-core-project-templates(OPTIONAL), com.atlassian.jira.collector.plugin.jira-issue-collector-plugin(OPTIONAL), com.atlassian.jira.ext.calendar(OPTIONAL), com.atlassian.jira.gadgets(OPTIONAL), com.atlassian.jira.jira-core-reports-plugin(OPTIONAL), com.atlassian.jira.jira-issue-link-applinks-common-plugin(OPTIONAL), com.atlassian.jira.jira-issue-link-confluence-plugin(OPTIONAL), com.atlassian.jira.jira-issue-link-remote-jira-plugin(OPTIONAL), com.atlassian.jira.jira-issue-nav-components(OPTIONAL), com.atlassian.jira.jira-issue-nav-plugin(OPTIONAL), com.atlassian.jira.jira-project-config-plugin(OPTIONAL), com.atlassian.jira.jira-projects-issue-navigator(OPTIONAL), com.atlassian.jira.jira-projects-plugin(OPTIONAL), com.atlassian.jira.jira-quick-edit-plugin(OPTIONAL), com.atlassian.jira.jira-share-plugin(OPTIONAL), com.atlassian.jira.jira-software-application(OPTIONAL), com.atlassian.jira.jira-view-issue-plugin(OPTIONAL), com.atlassian.jira.mobile(OPTIONAL), com.atlassian.jira.plugin.ext.bamboo(OPTIONAL), com.atlassian.jira.plugins.inline-create.jira-inline-issue-create-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-admin-helper-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-bitbucket-connector-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-development-integration-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-dnd-attachment-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-importers-bitbucket-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-importers-github-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-importers-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-importers-redmine-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-importers-trello-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-software-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-transition-triggers-plugin(OPTIONAL), com.atlassian.jira.plugins.jira-workflow-designer(OPTIONAL), com.atlassian.jira.plugins.webhooks.jira-webhooks-plugin(OPTIONAL), com.atlassian.jira.plugins.workflow.sharing.jira-workflow-sharing-plugin(OPTIONAL), com.atlassian.jira.plugins.workinghours(MANDATORY), com.atlassian.jira.project-templates-plugin(OPTIONAL), com.atlassian.jira.rest(OPTIONAL), com.atlassian.jirafisheyeplugin(OPTIONAL), com.atlassian.labs.hipchat.hipchat-for-jira-plugin(OPTIONAL), com.atlassian.mywork.mywork-jira-provider-plugin(OPTIONAL), com.atlassian.plugins.helptips.jira-help-tips(OPTIONAL), com.atlassian.servicedesk(MANDATORY), com.atlassian.servicedesk.servicedesk-lingo-plugin(MANDATORY), com.pyxis.greenhopper.jira(OPTIONAL)].  Disabling...

 

On the Atlassian Help Page it says I should check the pluginstate...the thing is: these plugins do not exist, but why?

https://confluence.atlassian.com/jirakb/service-desk-installed-but-not-enabled-found-dependent-enabled-plugins-for-plugin-800703376.html

 

is it safe to change my service desk project to another project type, restart JIRA, reinstall service desk and change back to project type "service desk"?

The add-ons might not exist because you have been messing with the file system.  Hard to say without knowing exactly what you have been trying.

However, it does sound like everything is runnning now.  So yes, it is fine to change project types, and re-install Service Desk (via manage applications!) and change the project type again if you need to.

well i reverted my changes with the 3 jar files as mentioned earlier. Did you look the help page I mentioned where it was explained?

in my log extraction there are just 3 mandatory plugins:

 com.atlassian.jira.plugins.workinghours(MANDATORY),
 com.atlassian.servicedesk(MANDATORY),
 com.atlassian.servicedesk.servicedesk-lingo-plugin(MANDATORY)

 

working hours exists and started

servicedesk exists but not started

lingo exists but not started.

the question or fear is when changing my project type can I change it back to "service desk" and the "project" will work like before?

 

secondly I could find an old entry:

http-nio-8081-exec-13 WARN      [internal.utils.context.CustomerContextServiceImpl] Unable to flush permissions cache
org.eclipse.gemini.blueprint.service.importer.ServiceProxyDestroyedException: service proxy has been destroyed

which appears once and never again during trying reinstallation

>the question or fear is when changing my project type can I change it back to "service desk" and the "project" will work like before

Yes, I answered that before.

I'm really not sure what is going on now, as there's only snippets of information here, and not the stuff we probably need to see.

I take it you have restarted JIRA and then tried to install the Service Desk again, via the application manager?

0 votes

Hi @Guido Lepping

I thank you so much for this! It happened to me too. I'll ask Atlassian Support to avoid this problem to happen in the future. I'm marking this in my browser!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

23,044 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you