It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Service Desk Application Will not Install after JIRA Core upgrade to 7.4.2

I have update our JIRA core recently and the JIRA Service Desk Application cannot be installed . I can see the button install as below :

1.png

When i click install though i get "An unexpected error occurred. Refer to the logs for more information.". I have tried reinstalling jirs service desk using the linux installer . i have rebooted the server but nothing still the same thing .

 

Below are the logs:

2017-08-03 14:30:30,862 UpmAsynchronousTaskManager:thread-1 INFO kleanthis 1017x212x2 jpb7is 192.168.6.114 /rest/plugins/1.0/available/featured [c.a.plugin.loaders.ScanningPluginLoader] No plugins found to be installed
2017-08-03 14:30:30,907 UpmAsynchronousTaskManager:thread-1 INFO kleanthis 1017x212x2 jpb7is 192.168.6.114 /rest/plugins/1.0/available/featured [c.a.plugin.manager.DefaultPluginManager] Updating plugin 'com.atlassian.servicedesk.application' from version '3.6.2' to version '3.6.2'
2017-08-03 14:30:30,910 UpmAsynchronousTaskManager:thread-1 INFO kleanthis 1017x212x2 jpb7is 192.168.6.114 /rest/plugins/1.0/available/featured [c.a.plugin.loaders.ScanningPluginLoader] Removed plugin 'com.atlassian.servicedesk.application'
2017-08-03 14:30:33,409 UpmScheduler:thread-3 WARN kleanthis 1017x212x2 jpb7is 192.168.6.114 /rest/plugins/1.0/available/featured [c.a.upm.pac.PacClientImpl] Update check request may take longer because of the number of add-ons

 

Can anyone help with this?

2 answers

4 votes

Hi Kleanthis,

I'm sorry to hear you're running into that issue.  Here is what I would do:

  1. Check to see if Service Desk is disabled:
    select * from pluginstate where pluginenabled = 'false'; 
  2. If you find anything with that query:
    1. Stop JIRA
    2. Run the following SQL query:
      • UPDATE pluginstate SET pluginenabled='true' where pluginenabled = 'false'; 
      • Note: If you're using Oracle be sure to commit the change.
    3. Restart JIRA

Try those steps and let me know the outcome.

Cheers,

Branden

Thank you! I was having this same issue and this did indeed resolve it. I had other plugins disabled and needed to update only servicedesk and jira software.

UPDATE pluginstate SET pluginenabled='true' where pluginkey = 'com.atlassian.servicedesk.application';

UPDATE pluginstate SET pluginenabled='true' where pluginkey = 'com.atlassian.jira.jira-software-application';

This hasn't worked for me...

Same problem here, fix worked.

But not before I've spent about 4 hours uninstalling, re-installing, rolling back, manually replacing plugins etc.

Might be worth writing this up somewhere a little more prominent?

Same problem for me with JIRA Core 7.8.2 and JIRA Service Desk 3.11.2 (I tried many combinations of plugins versions before I found this solution).

There was a plugin with name "com.atlassian.jira.plugins.workinghours" in pluginstate and pluginenabled parameter as false, after I ran db fix, it's working.

Thanks,
M.

The query fails to run with following error:

Msg 208, Level 16, State 1, Line 1
Invalid object name 'pluginstate'.

Any ideas?

tanx

i have same problem and its now solved!

How did you solve it?

I found this issue after upgrading to 7.5. and this solution did in fact resolve it. I'd like to know why this would've happened?

Same for me. It worked after upgrading to 7.5

After restarting I found Service Desk as 'installed' but needs update in Applications. after downloading it was updated and everything went well

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Calling all Jira Cloud users! Give us feedback on our exploration of a new navigation.

Hi everyone! My name’s Matt and I’m a product manager at Atlassian. I work in the navigation & findability space for all our Jira Cloud products. We’ve been working on trying to improve the exp...

1,051 views 16 12
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you