Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,621
Community Members
 
Community Events
165
Community Groups

Scriptrunner Webpanel Fragment missing after JIRA restart

Edited

I recently added a custom web panel using Scriptrunner fragment (using this tutorial: https://mraddon.blog/2020/03/05/show-aggregate-logged-time-in-time-tracking-section/) but after a routine server restart the webpanel has gone and adding new webpanels no longer works.

My other scriptrunner customisations such as scripted fields are all working correctly.

Is there an additional step required to accommodate server restarts? Not seeing any errors in the Script runner admin panels.

(Edit: I also note that in the manage apps admin panel it's correctly showing the module as active "ScriptRunner generated web panel")

2 answers

2 accepted

1 vote
Answer accepted

Thanks for the tip @Peter-Dave Sheehan - so this turned out to simply be a typo in the customfield name that in turn caused the webpanel to not load at all.

1 vote
Answer accepted

Try to disable scriptrunner in the manage-apps screen, then when you re-enable it, follow the log output in your atlassian-jira.log file for any clues.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you