Same filter, different results - Chart results and issue navigator search for the same query

Hi,

Explaining the issue in detail,

  1. Create a query where we search a particular customized field value for a single issue type
  2. Export the results in a 2d chart
  3. The chart shows missing customized field value count for Open issues as 8
  4. When we click the count '8', the issue navigator lists just 6 issues.

To re-check when we put down the directly in the issue navigator, using the Order by external id, the missing customized field value count is actually 8.

2016-05-11_14-06-11.png

2016-05-11_14-07-07.png

2016-05-11_14-05-00.png

1 answer

1 accepted

2 votes
Accepted answer

Hi,

it is easy! In the second filter you forgot about "Bug type" is EMPTY

Hey Michal,

Thanks for the response. I guess I have not made myself clear here. Let me explain again, the first screenshot (chart) shows 8 results whereas when we click on '8', the issue navigator just shows 6 results instead of 8. 

The third screenshot I have put to make it clear that there are actually 8, but the issue navigator shows wrong results for the chart (in the 2nd one).

Do you have any idea why this happens?

Could you show us the JQL of the filter behind the 2d chart?  And then the JQL it generates when you click on the "8" (and get 6).

It could also happen if you don't have permission to view all 8 issues

Hi Matt,

It could not be the permission issue, because I have the superadmin access.

 

Hi Nic,
PFB queries used:

  1. Query for the chart - issuetype in ("Internal - Defect") AND project = "Crestel BSS 6.0" ORDER BY cf[11740] DESC
  2. When we click on '8', the issue navigator shows this JQL - issuetype in ("Internal - Defect") AND project = "Crestel BSS 6.0" AND status = Open AND "Bug Type" is EMPTY ORDER BY cf[11740] DESC

 

PS. cf[11740] is the issue id for the customized field 'Bug Type'.


Hope this helps.

Admin access has nothing to do with the visibility of issues - it lets you have admin rights, not see/do anything (Admin rights include the right to set up the system so you can see everything of course)

The filters look good to me, so it suggests a broken index.  Could you try re-indexing the project?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,667 views 18 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you