It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Resolution won't set in one specific project

Using Jira Cloud, I'm an intermediate (self-taught) admin. 

  1. I setup a new workflow for a different project (TROVR) and everything works great. (See Pic A)
  2. Setting up a separate workflow for a new project (CTA) and the resolution refuses to set
  3. I've transitioned 3 test issues roughly 8-10 times after trying different "solutions" found in the community, to no avail.
  4. I have setup the first post function as "The Resolution of the issue will be set to Declined". (See Pic B)
    • I moved it to be the second post function. Didn't work.
    • I moved it to be the last post function. Didn't work.
    • I used the default resolution of Done. Didn't work.
    • I deleted the "Rejected" transition and re-created it. Didn't work. 
    • I used the workflow for TROVR (see #1). Didn't work.
  5. I verified the Resolution of Declined is correctly setup. (See Pic C)
  6. You can see that for my 3 test issues, the resolution isn't set at all. (See Pic D)
  7. These test issues have been transitioned using the "Rejected" transition (seen in Pic A) many times, but the resolution won't set!

What I did find is that the history of the issues shows I've set the resolution (when it transitions) but as soon as I re-run the search, the resolution is still showing empty. (See Pic E)

 

Pic A

Pic A.png

Pic B

Pic B.png

Pic C

Pic C.png

Pic D

Pic D.png

Pic E

Pic E.png

1 answer

0 votes
Jack Community Leader Oct 02, 2019

lots of great screenshots! thanks for sharing. My first suggestion is to ensure that you have published the workflow.

Thanks! I wish it was that easy, but I tried that. It was just quicker for me to navigate to the transition through edit. Here's showing it as published:

2019-10-02_12-46-06.png

 

EDIT: Just to be 100% certain, I tried it again. Here's the history log and the search I ran after that, showing the resolution still doesn't show as set -- even though the history log says I updated it. 

2019-10-02_12-51-43.png

 

Jack Community Leader Oct 02, 2019

another thought - do you have a custom field called Resolution and mistakenly either setting that or setting the real one but viewing the other in filter result? Long shot but I have sure seen it happen.

Jack Community Leader Oct 02, 2019

could you check the detailed issue view just to confirm that it isn't being set. something like this.... (new issue view)

resolution.jpg

Unfortunately for me, it's neither of those.

Custom Fields (letter Rs)

custom fields.pngDetailed Issue View

detail view.png

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

303 views 1 3
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you