Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Resolution is not displayed with the new issue view

hi.

When I view an issue (story, sub task) the resolution is not displayed in the new issue view.

only if I switch to the old view, I can see it.

Is it on purpose or a bug?

9 answers

Hi,

I'm having similar problem. When I update the screen - I can see the resolution field when I create a new issue (Bug / Story). But,  I still cannot see the resolution when I view the issue in the issue detail page or on a board page.

Hey, the same issue facing for almost 3 weeks but still not getting any way to resolve it as it becomes very difficult to change the resolution from old view. Also in a new view, if we can not have a resolution field it is unable to search resolution's other status through search issues and filters.  

How is this issue not addressed yet? I just filed a support ticket for the exact same problem. New UI is entirely broken in respect to 'Resolution' field. As others have posted the only way to consistently view/edit it is using the 'old' jira view, which has its own pitfalls.

Does anyone know if this issue has been resolved yet, causing a few issues with users having to flick between the old and new UI for the purpose of having issues which are actually able to be put into a report? 

If not are there any workarounds which may work other than potentially having two statuses which would reflect the resolution fields?

Hi @Steven Lloyd - From what I can tell, the only way to get access to the Resolution field is via a transition screen; see Resolution best practices here: https://confluence.atlassian.com/cloudkb/best-practices-on-using-the-resolution-field-968660796.html

and @Tarun Sapra 's note here: 

https://community.atlassian.com/t5/Jira-Software-questions/Resolution-field-in-new-issue-view/qaq-p/1091802

"But in the classic project (with new cloud )view, you can add a transition screen to the workflow transition and the transition screen can have the resolution field which has list of options which the user can select."

We are also facing this issue. Resolution field is not displayed in the new view.

Resolution field is not editable in the new UI, this is a missing feature. Really poor

as a workaround, quickly switch to the old view to edit the resolution.

Thanks, Gil, but this won't allow me and my team to use the new interface again, which is a real shame. The type of resolution is something that affects the KPIs of the entire company and we cannot overlook them.

We will continue to use the old interface

How often do you require to adjust the resolution?

If you have to adjust it for every issue you're closing then I'd say there's a problem with the process you're implementing, not Jira itself.

If this is something you do once in a while because team members selected the wrong resolution, then switching to the old view just for fixing the resolution and back again to the new view, is a simple workaround. Not convenient, but still works for now.

If you are using automation 4 jira, you can create a rule that will bulk fix the resolutions for you.

Gil, see,

I would ask you not to be offensive.

You don't have to, nor can you decide on a company's process.

My company could bill more than yours in terms of process, or have disruptive procedures that would improve your work and certainly wouldn't allow you to give such superficial answers to a customer.

I admire Jira and his management, really, but that doesn't mean it's better than other companies big or small.

Please don't ruin the perfect image I have of your company.

The truth is this: you had functionality and it disappeared in the new interface, I would make amends and since it is a small effort I would re-add it, or explain that it is not possible and why.

So please refrain from judgment, and remain committed to this specific issue. Can it be done? Yes or NO and why.

My two cents if I can:

I believe you have a problem in your answer process, admit a lack and this will help your company gain credibility and not frustrate the customer. People featured in this 3D and members of their companies will not use the new interface for this silly reason. And who knows how many other companies have the same problem. In addition, suggesting to change company procedures is a really bad communication idea, please review it, this is the second time I read your irreverent and offensive answer, please change the register.

Thanks!

Like # people like this

I wasn't being offensive to you or to your company.

The fact you took it this way has nothing to do with my intentions or explanations.

Jira should conform to your processes and not the other way around.

But if your process requires frequent resolution changes, yet Jira doesn't cater for that process, I simply suggested that there might be a problem with the process and the conclusion is that maybe the process should be changed to cater for this limitation.

It was to provoke thought, not to dismiss how you conduct your processes.

At the end of the day, it's your or your company's decision. I'm still surprised you took this advice as being offensive, while I was trying to provide a workaround, not stating that you are doing something wrong.

I also suggested another solution to use Automation 4 Jira. How could you see offensiveness here?!

I think the way you responded to me was demanding and rude. You are clearly frustrated and deciding to vent out on me in a public forum. That something for you to think about. I'm complete with my response to you. Nothing was offensive, you're being way out of line and reading too much into it. 

Enjoy your day, and please refrain from mentioning me in this forum again.

This thread was opened by me. You are more than welcome to open your own thread and vent out on people there.

Like Erin Henne likes this

Unfortunately, I don't think there is empathy in your words, please avoid judging it is still my invitation, if you think you are wrong don't be afraid to apologize, if it's a hard time for you don't let it fall into your answers in a public forum,

If you want I can do a social survey and see who gives reason to whom.

In any case, no concrete answer has been given here, I try again if this does not yet generate the problem in those who ask the question without giving answers:

In the new interface, there are many missing features like this, the question is:

What is Atlassian doing for this specific request?

Are you planning to restore this functionality?

Yes or no? And If not why?

Thank you!

wow! you're a piece of work.

ask Atlassian, raise a support ticket. go be angry at them.

open your own thread.

yeah, I have zero empathy for narrow-minded people like you. I think Jira is beyond your abilities. find another solution where you can take your frustrations elsewhere.

I'm more than happy to respond in this manner in a public forum because you are a snowflake thinking people owe you something and being offended by suggestions.

 

I'm not planning to restore any functionality because I'm not working for Atlassian! I never worked for them myself.

I'm a user who encountered an issue and found a workaround that I can live with so I can manage my business without bitching around.

Have a problem? raise a support ticket to Atlassian and ask their support.

What a terrible person, I really don't have words.

Have a great day

Like Gil likes this
0 votes

Hello,

Try to add the resolution field to the view screen.

I have tried adding it but simply can't get it to appear. I ended up reverting to the old view and it's there

Like # people like this

It's easy to miss, but it appears.

image.png

 

See the 'Done'

That's where the resolution is.

Like # people like this

Hi, I'm having the same issue.  I have 'resolution' listed in my Issue Screen Layout but its not visible to update on the new screen layout.   In your illustration above, where did you set the resolution to Done ?

Agree, it is visible on the Issue but is not editable in the new UI. The only way to edit it is in the old UI, which is then reflected in the new UI. 

I have tried removing and adding the field again on the "Configure Screen" page but no success.

Like # people like this

I have the same question as Milind, is there anyway to have the "resolution" editable in the new UI?

Thanks

While it shows it does always show the same value: Done. Even if I set the resolution to a different value. BUGGY!!!

@Alexey Matveev _cPrime_  Timeline on fix here? This is completely screwing up our reporting.

I am having the same issue. In the new view, only STATUS is available. RESOLUTION is ONLY available in the OLD UI. 

 

PLEASE ADVISE!! Is this something which will be fixed soon?

Add it to the view screen however pay attention that if you set a resolution, it will be shown by the closed tickets even if the status is not closed ...it can be confusing for the customers. Also if you add it to the screen you have to provide a resolution at an early stage, and it does not always make sense. (I had the same issues not long ago)

As @Milind Thakur pointed out, I can only find the way to change it, if I use the "old UI". Where can I changed it in the new UI?

Like Kourosh Vuarnier likes this

Has anyone tried updating your workflow to have the closed status loop back into itself? If you do this you can progress the status to the same status you are in and in turn update your resolution. 


Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you