Problems with workflow

I Created new workflow called "Lipe-workflow", using "Diagram" and "text". I add one step more to default workflow.

Only one jira project is using this new "Lipe-workflow", but this creation process changed existing workflow ("ML1.2 workflow") and added this new step also to another jira workflow!!! So now we have the changed workflow in multiple Jira projects (which uses this ML1.2worklow). If i look using "Diagram" this ML1.2workflow I can see the new step there (should not be there), but If I look from "text" I can not see this new step there. It seem to be bug in the "diagram" functionality :(

System tells that the ML1.2Workflow has changed at 17/Mar/14 2:05 PM. (not today when I created the new Lipe-workflow)

What should we do???

Version 6.1.4
Build Number 6159

5 answers

1 accepted

0 votes
Accepted answer

How did you create "lipe-workflow"? It sounds like you've actually created a draft of ML1.2 and not copied it to a new workflow.

Start with the basics to get this fixed. Look at the list of workflows you have. Then look at the workflow-schemes you have for the projects. There should be a scheme for Lipe projects and another scheme for mL1.2 projects.

(The workflow change date represents your last edit to that workflow)

Problem solved: "Linked status" (which is global) was changed -> this cause the problem. We changed the status as it was and now works again :)

Lesson was: should be very carefull which parameter is global and which is per project.

Ahh, you changed the status, not the workflows. Right.

Generally, watch out for status and screens - as you've found, the workflows refer to these, but they're taken from a global list

Well, I was editing workflow and creating new step and one new status. And I managed to create new workflow, but somehow I managed to change existing status to new (Instead of creating new status) :(

I know, it's a bit of a pain. Older versions of Jira didn't have the workflow designer, so it was hard to make this mistake, but the newer versions have enabled you to amend the global lists without realising that they're global. Easy to undo of course, but still a bit of a pain when you're new to hacking workflows.

This is now solved :)

Would be polite to mark the correct answer as correct. Or, if it wasn't that, then explain what the actual problem was.

Yes, sorry I don't know how :( to mark

Same way you marked your own answer correct - the tick to the left of the avatar.

hope I managed

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,731 views 17 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you