Problem with loading BIRT Reports directly from JIRA

Hello!

I created some BIRT Reports based on JIRA (the Data Source is the JIRA Server) and now I want to open them directly from JIRA. In JIRA, the plugins "SQL for JIRA" and "Reports and Charts (BIRT) are installed and are listed in the add-on section under KINTO SOFT LTD.

I created a Dashboard that has one gadget (SQL for JIRA Report). I uploaded the reports to  "Reports and Charts (BIRT)" in the add-on section. After uploading them I wanted to access them from the Dashboard (from another report, that doesn't use any data source and only works as a menu that links to the other reports), they loaded for a while, but nothing happened. I went back to the Reports and Charts section and tried to open them from there, but an error showed (java.lang.IllegalStateException: The viewing session has expired.). I opened the Dashboard again and not even the first report without any data source showed (same error as from the Reports and Charts section). After logging out and in, the first report showed, some reports worked and some loaded for a while, but then the screen was blank (They all have the same data source and worked fine in Eclipse using a test server.). I logged out and in again, and now the ones that worked also load for a When I try to start them from eclipse, the reports load forever.

I noticed that in the add-on section it says "This add-on must be installed in order to enable this feature. Please contact your administrator." in the tag "SQL for JIRA Driver". How can that be if it sometimes works? And sometimes, when i click on Reports and Charts, it loads for a while and then there is also an error (502). Other times it works fine, mostly after logging out and back in again.

I use the driver from this site https://kintosoft.atlassian.net/wiki/display/SFJ/Accessing+to+SQL+for+JIRAkintosoft_jdbc4jql_driver_1.0.0.jar), which worked fine for the test server. Here https://marketplace.atlassian.com/plugins/com.kintosoft.jira.birt_viewer/server/versionhistory it says, I need a driver for JIRA 2.2.2 or above. Can this be the problem?

2 answers

the SQL for JIRA Driver version is not the problem. It looks like you are using the 3.0.0 version or above which is fine. THe problem is clearly related to the JIRA user's session and how the SQL for JIRA - Eclipse BIRT plugin deals with sessions..

The SQL for JIRA - Eclipse BIRT reports are JIRA user's context aware and it looks like the context (HTTP session) is missing when you click on any link in the menu gadget. Furthermore, when BIRT reports run embedded in JIRA gadgets they run in iFrames, so it looks like you are invoking content across iFrames which might be things more complex.

I wonder why you need use an extra gadget as menu when this feature (menus) is nicely supported by BIRT running in the same gadget/iframe which could help to avoid session issues

Thank you for your reply!

I tried loading the report (that uses the JIRA data source) directly into a gadget, without the menu report, but that doesn't work as well. It's loading for a while and then nothing happens. So I'm not sure if it would help to get rid of the menu.

Furthermore, the Charts and Reports page in the add-on section won't load as well and gives me a 502-error.

Perhaps the SQL is not enough optimized and it works fine in your test environment but it takes a lot on production with more  data. I've seen users decreasing the time required to perform a SQL for JIRA query from some minutes to few seconds.

I don't see any relationship among the 502 error, no results, etc.. 

It would be better if you create an issue on the JIRA instance to resolve this

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

540 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you