Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,414,339
Community Members
 
Community Events
170
Community Groups

Possible to remove 'none' in custom field list?

I created a custom field that is a drop down list and noticed that it contains the value 'None'. I do not want this in the list, but rather only use the values I created in the drop down list. Is this possible?

Thanks

9 answers

You have to make the field required, then the 'none' won't be there anymore.

No, it is still there after I make it required in field configuration

See my answer from 2019 - you also have to define a default value.

Like Christiane Weidenbach likes this

At the moment (in Jira 7 and 8) you have to make the field mandatory and give it a default value - then the "None" disappears. 

Using scriptrunner behavior, you can use something like below. 

Set the field as required/not required (on behavior side, not JIRA's field configuration), depending on your use case.

In my case, I want my severity field to be set as required only on a certain project, without having to create additional field configuration (as I have one massively shared field configuration - for process standard in my company). So I set the severity field as required through behavior, but the 'none' option stills show. So, use below :script 

import com.atlassian.jira.component.ComponentAccessor
import com.atlassian.jira.issue.customfields.manager.OptionsManager
def optionsManager = ComponentAccessor.getComponent(OptionsManager)

def severity = getFieldByName("Severity")
severity.setAllowInlineEdit(false)

def sevcustomField = customFieldManager.getCustomFieldObject(severity.getFieldId())
def sevconfig = sevcustomField.getRelevantConfig(getIssueContext())
def sevOptionsOriginal = optionsManager.getOptions(sevconfig)

/*define the select list manually, do not include the 'none'*/
def sevOptionsCustYes = sevOptionsOriginal.findAll { it.value in ['Critical', 'Serious','Medium','Low'] }

severity.setFieldOptions( sevOptionsCustYes )

Thanks @Azfar Masut

We don't have Script Runner on our server, but I can try and persuade our board to invest in it. But when I tested on my own personal instance it seemed to do the trick.

Regards

Like Azfar Masut likes this

@Liam Maeder - great to hear that! Do help to upvote my answer if it helps!

btw, scriptrunner is worth the investment, especially if you're supporting large number of users (in my case, 10k userbase). Lots of other customization can be done with SR to deal with the small custom request from your users. I would say, go for it!

The behavior script worked perfectly fine.

Thanks @Azfar Masut .

Like Azfar Masut likes this

The behavior script was very useful and it worked fine.

Thanks @Azfar

Like Azfar Masut likes this

Hello @Azfar Masut ,

 

This solution seems to be the one that I need, but I have a question. You state that I need to set the field as required in behavior. I'm not sure how to do that, I know about the field config setting required, but not about "behavior." Can you point me in the right direction please?

Set the field as required/not required (on behavior side, not JIRA's field configuration)

A dirty workaround - Make the custom field Mandatory and "None" option will disappear.

Only solution (without any coding) is to:

  • first make the field mandatory
  • Then, set a default value for that field 

You can also add an option that's just a space and make that the default value. Of course, you still need to make the field mandatory

Step one: Make the custom field not "Multi-select value" meaning, "None" in that selection as part of edit the custom field.

Step two: Make the field mandatory/required

This works for me

@Azfar MasutMasut,

 

I am using the below code to display options of the Location field but I see none option by default on the request form but I do not want that instead, I want International to show up. Can you please help.

 

import com.onresolve.jira.groovy.user.FieldBehaviours
import com.onresolve.jira.groovy.user.FormField
import com.atlassian.jira.component.ComponentAccessor
def customFieldManager = ComponentAccessor.getCustomFieldManager()
def optionsManager = ComponentAccessor.getOptionsManager()

def Location = getFieldById("customfield_14444")
Location.setAllowInlineEdit(false)

// Get access to the required custom field and options managers
def customField = customFieldManager.getCustomFieldObject(Location.getFieldId())
def config = customField.getRelevantConfig(getIssueContext())
def options = optionsManager.getOptions(config)
def optionsMap = options.findAll {
it.value in ["International",
"United States"] // list of options you want to show
}
Location.setFieldOptions(optionsMap)

looks correct to me, can you double check and ensure the location field doesnt have 'none' set as default? (from the JIRA custom field setup page)

I am sure no default value is set. 

Try setting International as default instead. Is the 'None' option still showing after that?

Mizan Rising Star Jun 04, 2012

Hi Jobin ,

Do you know what will be a javascript/groovy solution for making "None" as the first option . I have raised a question here

Thank you

I have a similar issue where i keep getting this none option but i have a default value already set and mandatory, yet the none option is still present. Is there no there way to get rid of it

Like # people like this

I'm having the same issue as @Liam Maeder. The Field is required, but none still shows up; what's worse, it acknowledges 'none' as acceptable, so it basically renders the 'required' part of the field useless.

Like # people like this

I am having the same issue. What is the point of making a field required if none will be an option? Is this a bug? 

Like # people like this

Suggest an answer

Log in or Sign up to answer