Oracle "cannot insert NULL into" error during database setup

Berk Karabacak April 15, 2020

I am doing a clean installion of JIRA 8.5.3 to Oracle 19C database and i am using JDBC 19.3 (ojdbc8) driver from Oracle®. I have granted permissions to the user as suggested in here.

 

Database connection is succesful but during database setup it fails with this error:

Technical details

Log's referral number: 37e285e6-0e6f-4d3d-83f2-a168113613df

Cause

Referer URL: http://10.1.60.235:8080/secure/SetupDatabase!default.jspa

com.opensymphony.module.propertyset.PropertyImplementationException: while inserting: [GenericEntity:OSPropertyEntry][propertyKey,jira.i18n.language.index][entityName,jira.properties][entityId,1][id,null][type,5] (SQL Exception while executing the following:INSERT INTO propertyentry (ID, ENTITY_NAME, ENTITY_ID, PROPERTY_KEY, propertytype) VALUES (?, ?, ?, ?, ?) (ORA-01400: cannot insert NULL into ("JIRAUSER"."PROPERTYENTRY"."ID")

))

com.opensymphony.module.propertyset.PropertyImplementationException: while inserting: [GenericEntity:OSPropertyEntry][propertyKey,jira.i18n.language.index][entityName,jira.properties][entityId,1][id,null][type,5] (SQL Exception while executing the following:INSERT INTO propertyentry (ID, ENTITY_NAME, ENTITY_ID, PROPERTY_KEY, propertytype) VALUES (?, ?, ?, ?, ?) (ORA-01400: cannot insert NULL into ("JIRAUSER"."PROPERTYENTRY"."ID")

    ))

     at com.opensymphony.module.propertyset.ofbiz.OFBizPropertySet.setImpl(OFBizPropertySet.java:260) [propertyset-1.5.jar:?]

     at com.opensymphony.module.propertyset.AbstractPropertySet.set(AbstractPropertySet.java:502) [propertyset-1.5.jar:?]

     at com.opensymphony.module.propertyset.AbstractPropertySet.setString(AbstractPropertySet.java:300) [propertyset-1.5.jar:?]

     at com.atlassian.jira.propertyset.JiraCachingPropertySet$9.run(JiraCachingPropertySet.java:421) [classes/:?]

....

1 answer

0 votes
Earl McCutcheon
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
April 17, 2020

Hello @Berk Karabacak ,

While I have not seen this exact error before, we will need to do a bit of troubleshooting to narrow down the cause, there are similar ORA-01400 errors that we know about on older version noting that the following are close but not exact, and occuring in various different locations with different causes:

One suggestions that is offered in the above KB's is to do a clean install from an XML backup or contact support to get a detailed view of what is occuring in the logging:

Resolution

(info) Another alternative to tackle this problem is to have fresh database set up together with an XML backup of your instance. After running through the setup wizard (you can complete it as a fresh installation or perform the restoration of XML backup during the setup), the issue should be gone after the XML backup restoration is completed.

But Just to be clear, in your install this error is occuring on a fresh clean install with no data restore occuring correct?  i.e. new DB + New Jira 8.5.3  and you're just setting up a brand new install not upgrading or importing data.

If this is the case an no restore is occuring just install on the surface this seems like an error that would occur if the DB user quota limit was not set to unlimited as covered in "Connecting Jira applications to Oracle" via the create user command:

create user <user> identified by <user_pass> default tablespace <tablespace_name> quota unlimited on <tablespace_name>;

As the error is very similar to the This Microsoft SQL Server DB error when the SetNoCount option is missing on the alternate DB type noting the table encountering the NULL error is the insert to:

propertyentry

But alternatively I found the following thread on a older version of Jira and Oracle that also looks to line up here, and in this particular case it was that the DB user creation set incorrect permissions on the tablespace, and pumped out a matching error but the user noted:

The error printed is completely not the real problem! (oracle seems to have a funny way of reporting errors....)

But do check this one out as the user noted the steps used to diagnose and correct error output leading him to the solution in that case:

I recomend checking the quota limit and the permissions then Let me know what you find.

Regards,
Earl

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