Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,233
Community Members
 
Community Events
176
Community Groups

Message Custom Field (for edit) field on Cloud not displaying on edit or create screen

I created a field of type Message Custom Field (for edit)", associated it with edit/create/display screens but I can never see this field when editing, creating or viewing  it. the "Where is my field" tool indicates that it should be on the screen, all validations it does come back OK with no errors  but I'm not seeing the field name. Am I doing something really dumb? I've never used the message custom field field type, so I'm wondering if I missed a step somewhere or I don't understand what it should be doing.

Thanks,

Jay

1 answer

1 accepted

1 vote
Answer accepted

Hello,

When you created the edit message custom field, you should open the configuration of the field and set the default value for this field (Issues -> Custom Fields -> your field -> Configure). On the edit screen you will the message, which you provided in the default value.

Thanks Alexey,

It was a matter of me not understanding what the field was supposed to do! I thought that the Message Custom File (For edit) would allow me to display preset text into a field and then allow user to edit the field during issue creation. Once I put default data into field as you suggested I saw the behavior and then understood what it was really doing. Thanks for the help.

You are welcome!

Deleted user Jan 04, 2019

This solution does not work for me.

 

I tried entering these as default values. None made the field display

  •  (space)
  • .
  • default value

I'm a bit stuck on this - when I put a default value of "my random bit of text" in a message field for edit, I get that displayed on my create and edit screens.

I suspect this might have to to to Atlassian support to debug, at https://support.atlassian.com/contact

@[deleted]

You need to put a value, which you want to be displayed in the default value for the message custom field.

Like Steve McKenzie likes this
Deleted user Jan 07, 2019

@Alexey Matveev _Appfire_

As I said above, I did populate the default value with many differnet things.

But the field still did not show up.

 

So, no, that "solution" did not work.

@Nic Brough -Adaptavist- & @Alexey Matveev _Appfire_I have been using this function for a month, inputting a default "text" value.. We have had no issues at all... Randomly, this morning, I get into work and the default value is gone and I cannot get a default "text" value to save now.... Help?

@Valerie Padilla Hoping we get an answer here /\/\

Hi @Chris Lovvorn did you eventually get an answer to this? 

I'm experiencing the same issue. 

 

Thanks

Raphael

@Alexey Matveev _Appfire_ sorry to bring this issue live again but it doesn't seem to work for me. Do you know if it works on the latest version of Jira Cloud?  I added some description to the field but it simply does not show on create issue screen.  Any suggestions on what I may be doing wrong? 

Thanks

Thanks @James Paniagua . 

The problem I have is that it just doesn't show the description at all. It's like the Custom field doesn't exist.  I copied your description and pasted to my Custom Field and it still doesn't work.  The Custom Field (PER Process Info) was supposed to be displayed under the Info tab (first image). When you click on the show fields on the top right corner you can see the field exists (second image).  

 

Screenshot 2022-04-20 at 15.59.08.pngScreenshot 2022-04-20 at 15.59.56.png

@Raphael Lamas question, where are you configuring the description of the custom field? Does your project use a specific field configuration? If so, you might want to check there, as the field configuration scheme takes precedence over the custom field descriptions under Custom fields.

Good point @James Paniagua ! I've just updated the description to our specific field configuration, but it still doesn't show in the create issue screen. It shows correctly formatted in the Field Configuration Screen. 

Screenshot 2022-04-20 at 16.45.03.png

@Raphael Lamas , is this a Message Custom field (for edit)? I don't think you can use the description for this field that way in Cloud. This has to be set in the default value.

sample_field.png

Make sure you use the panel markup.

{panel:bgColor=#deebff}

my info panel here

{panel}
Like Fran likes this

Issue solved! That was exactly what I was doing wrong.

Many thanks @James Paniagua

Like James Paniagua likes this

Glad the issue is resolved @Raphael Lamas !

@James Paniagua Hi, I actually did exactly this and want to display my info field on a transition screen but it will not work.

Any idea on how to solve it?

 

EDIT: I found the answer, we just need to use the "(edit)" version of the field for this purpose.

Suggest an answer

Log in or Sign up to answer