It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Market place for JIRA: Method not allowed with this referer

Hi!
When I link to "Find new apps" in Jira or Confluence, I see next information 
"Oops! Looks like something went wrong while initializing. 

  • Method not allowed with this referer

"

What could be the problem?

5 answers

Hi, the same happens to me.

2 votes

Hi Community,

I found an example of a user with this issue in the Cloud support queue, and the issue was with a Google Extension named UMatrix and also an Ad Blocker add-on they were using in their browser.

Could you check if you have any ad blockers? If that's not the case, then you can try disabling all of your add-ons in your browser. See if the issue goes away. Then you can re-enable them one at a time until the issue returns.

Regards,

Fabian Alfaro

This error concerns the HTTP header Referrer-Policy.

In my case, the Private Internet Access VPN plugin caused the error. The solution was to de-select the "Disable website referrer" option in the plugin's settings. I also found that

  • turning off the VPN plugin eliminated the error, but adding Jira/Confluence to the whitelist did not. Evidently, adding sites to the whitelist does not bypass all functionality of this particular plugin.
  • disabling Nano Adblocker and Nano Defender had no effect on the error from Jira/Confluence, so the VPN plugin was the sole offender.

In brief:

  1. Find the setting or plugin that is preventing the browser from sending referrer information in the http response header.
  2. Change the setting or de-select the option to disable refferer information—or in other words, make sure the browser allows referrer information in the header from Jira/Confluence.

2020-01-30_17-53-14.png

Like # people like this

Yeah Same here! Really Annoying. I have been scouting the internet for a solution. Seems a ticket would be the right answer. I am also on Cloud. 

0 votes
Deleted user Mar 27, 2020

I have disabled an Ad Blocker and it worked. Installed what i need and enabled it again :)

Had this issue too using Brave browser. 

Disabling shields for the site fixed it...

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you