It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Logout 400 status error in Jira localhost

I'm testing a plugin on a local Jira instance that is created via the atlas-run command of the Altassian-SDK.

When I use the logout button, it leads to an error page with a status code of 400. The error seems to be that there are unencoded pipe "|" characters in the URL that Jira is unable to handle.
I know that the plugin doesn't cause the problem, as it still exists when the plugin is uninstalled. I also believe that the problem appeared because of an upgrade to AMPS version 8.0.2, which was necessary for a team-member to run a local instance of Jira.
After reading this discussion:
I tried to set the option in Tomcat's as mentioned at the very end. This unfortunately didn't solve the problem.

Any help with this would be appreciated.

1 answer

0 votes
Andy_Heinzer Atlassian Team Sep 10, 2019

Hi Tore,

I understand that you are seeing an error in regards to a pipe | character in a Jira URL when trying to logout using the SDK.  I would have expected this version of the SDK to avoid this problem.  But what I think might be happening is that the $Jirainstall/conf/server.xml file might not have the proper settings for this version of Apache's Tomcat that Jira is running.   There are more details about this configuration change in

From that page:

Steps to take

To solve the problem, edit the server.xml file, and add properties that make Tomcat accept special characters in the requests.

  1. Go to <Jira-installation-directory>/conf, and edit the server.xml file.
  2. Find all connectors your application is using. Just search for Connector in the file, or look at the example below.
  3. Add  relaxedPathChars="[]|" relaxedQueryChars="[]|{}^\`"<>"  to the connector properties in server.xml. For example:

    <Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;" maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false" maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443" acceptCount="100" disableUploadTimeout="true" bindOnInit="false"/>
  4. Restart Jira.

Try this and let me know if this helps,


Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you