Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal


  • Give kudos
  • Received
  • Given


  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Jira Language was changed without notice

Since a few weeks Jira is now displayed in Dutch. I never changed my language, i want everything in English. The extra weird part? If i go to settings, my language is still set to English (United States). It is not listening to my browser or other local computer settings either, everything i have is set to English. It must get the language based on my ip address.

How can I change it back? This feels like a bug to me.

1 answer

1 accepted

0 votes
Answer accepted

@Martin Schimmel , did you check this [Change your service desk project's default language | Jira Service Desk Cloud | Atlassian Support,

[Solved: How to change default language back to English?; ]



Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you