It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to change default language back to English?

Hello,

Last week I noticed Jira cloud changed the interface/default language the Dutch/Nederlands. I am Dutch but the Dutch language in Jira is terrible, I want it back to English. Does anyone now where I can change the language back to English? or if this is a Bug, where can I report it.

My settings

  • Index language is 'Dutch' (Nederlands)
  • Default language (Standaard taal) is 'Englisch'

Default language.png

25 answers

1 accepted

5 votes
Answer accepted
Daniel Eads Atlassian Team Apr 24, 2019

Hey all!

Thank you for the effort you’ve all put into detailing the issue with changing Jira’s language and the steps you’ve taken to get it working. In the last few months we resolved a bug that prevented English from being set in Jira’s preferences if your browser had another language set in its own preferences. After reviewing many of the cases you all described, I believe this issue should be resolved for everyone. Please let me know if you are still encountering trouble setting the language preferences!

Thanks,
Daniel | Atlassian Support

Looks good! Thanks

The problem seems to exists.

My browser says "English" as the language, however, JIRA shows it in some other language. (apparently, I cannot read it to identify the language)

 

Can someone please help?

Same problem here, my default language is set to English but it keeps displaying a different language (Jira and Confluence).

EDIT : The answer of Mitchel below fixed the problem as it was the web browser(Google Chrome) forcing the translation of the interface in a desired language. Changing to english your chrome language fixed it for me.

Like James Malgieri likes this

Reading this whole page it appears someone at Atlassian had the bright idea to allow the browser's language settings, on the browser that you are using for JIRA, overwrite the JIRA's own default language settings. see Mitchel Meijer Mar 05, 2018

To make a bad idea worse, now the time zone is somehow involved. For example, if you want JIRA text to be in English, set the time zone, for example, "Timezone: Region: Americas / GMT -05 (New York) < or any other US time zone"

Am I the only one who finds this totally unacceptable?

Like Geovanni Chavez likes this

Hey, for us the language also switched to not english anymore. Seems to take it by the timezone. How can we still use the default company language? Or set any?

I could switch it back at https://<domain>.atlassian.net/wiki/users/viewmysettings.action
Somehow it was set to detect by browser etc...  And first time we noticed it.

Like # people like this
Daniel Eads Atlassian Team May 20, 2019

Hey @Rajas Gujarathi - I've reached out to you via email. Based on your account's information, I think you might be on a Server instance rather than Jira Cloud.

@Julien MEYER I think that's unexpected behavior now - thank you for letting us know your setup. We'll dig into this a little more!

DH I'm New Here Jul 15, 2019

Screenshot 2019-07-15 at 16.52.25.png

As you can see, my settings are English for standard language, but it still is forcing swedish as that is the language of my brownser. 
This is a extremely poor way of handling language, if the owner of the project wants the sites to be in english for the customers it should also be shown in english. 

It gets very distracting when working in a multi-lingual and international team if everyone have different languages when they all prefer to have this site in english but there is no way to fix it.

This is a very old issue, it should be fixed.

DH I'm New Here Jul 16, 2019

Florian Scholz has the solution for a temporary solution and needs to be done individually on every persons profile.

Go to https://<YOURDOMAIN>.atlassian.net/wiki/users/viewmysettings.action 

and edit the settings to english (or other prefered language). 

 

I did change language in my browser but still had the site shown in swedish.
After doing what florian said, i finaly had the sites in english.

Jira has a new feature, that is translating based on your browser settings.

So in Chrome my language  was 'Nederlands (Dutch)'.

I changed my browser language setting to English and see there, Jira is in English again!  

Thanks, I've been looking for this :) Choosing the  user's default language may be based on the browser settings, but there should be an option to override this in the user's profile.

Like # people like this

Yes - thank you.

I have spend so much time trying to find out where to change the language settings for my team. And I totally agree, this shouldn't be automatic, there should be a way to override this.

Like # people like this

Thank you,

my Chrome language was set to English, but I had to reorder "Order languages based on your preference" to make Jira know I prefer English *more* than all other languages

Like Tamas Pusztai likes this

I have the same problem and thanks to this post.

I removed the Vietnamese language in Chrome and the default English is back.

Thank you!!

Not a good solution, as changing this in the browser impacts language selection on a lot of other unrelated websites. Jira already has a setting for defining the language, irrespective of the browser; it just doesn't work.

Like # people like this
Deleted user Nov 21, 2018

Thank you, big help here

My browser default language is English but it is showing Polish in my confluence. Google translates it to English. The experience is terrible!

Like # people like this

@Mitchel Meijer please remove the accepted answer as this still isn't solved actually. Atlassian please change this asap as this is terrible that I cannot even set the default language to English.

Correct it is still not resolved

If the default language is now based on the default setting for a browser then why does JIRA/Confluence have a default setting.  This is a terrible idea.

Like Wei-Ling Wu likes this

Dutch is my native language, but I need to report to the customer in English, so it is very inconvenient that JIRA shows everything in Dutch ! I really think the language setting in JIRA should be independent from the browser settings.

you should move the preferred language up to the top, in the chrome language settings. this will change Jira to your preferred language  

Hi, I also had to change my Chrome browser language setting.

Not very handy that the browser setting wins from the Jira backend setting...

Very frustrating, half Romanian, half English and I need English only.

While I'm a Romanian native, I don't want to translate every action on Jira from Romanian to English.

 

Changing browser settings didn't work, btw.

This makes Jira almost useless to me. It is a horrible trend in UI to assume the language from the browser or OS. Many of the terms used don't really exist in danish and the english terms are always used in speech. Backlog is called backlog and so forth, but for some reason translators insist on inventing words that make no sense and completely undermines the use of the product. Sorry, rant over! Please fix!

Is there someone at atlassian aware that this is still an issue? 

yes. I have the issue.

Hi,

 

I changed my default language in JIRA to Russian, however everything is still in English. 

It's ridiculous that I need to change my browser setting to be able to change language for an application.

Please add a setting so that I manually can change which language I want to use.

This solved my mixed language issue:

 

With the following settings, the UI is a mix of portuguese / english, no matter what languages are selected in general or personal settings

General settings:
Default Language: English (United States)
Timezone: Region: Americas / GMT -03 (Sao Paulo)

Personal settings:
Language: English (United States)
Timezone: Region: Americas / GMT -03 (Sao Paulo)

 

With this other setting, the interface is 100% in english or 100% in portuguese, base on the user personal settings

General settings:
Default Language: English (United States)
Timezone: Region: Americas / GMT -05 (New York) < or any other US timezone

Personal settings:
Language: English (United States) / portuguese (Brazil)
Timezone: Region: Americas / GMT -03 (Sao Paulo)

I got some success by changing my time zone too. Still have the French user profile but most of everything else is in English, even the pop ups from the French profile... Obviously, it's not just about getting the right language setup. My timezone however is now 7 hours late!

Just signed up to test Jira and I am struggling with this before creating a single issue. Not cool. Not willing to change my browser settings for this.

I had the same issue in a different Chromium-based browser (Yandex Browser) and was able to fix the nuisance by installing "Advanced Page Language Switcher" extension and setting my default language in it to English. Now I have Russian as my first language in the browser (which allows translating any content to Russian) and my JIRA is displayed in English.

It works for me too! Thank you so much I spent like 50 minutes struggling with it.

Oh boy! A new "language" plugin by proxy

Right now you must contact support to do those changes. 

Message I get from my settings when I am trying to change the language.

"Temporarily, currently only sysadmin can change indexing language and reindex all documents. Contact Atlassian Support if you need help. "

I need to get back to the English version of language as I can't  read Urdu don't understand or speak it. Please help me get back  to the English.Thanks.

I concur with the above. Let the Jira setting decide the preferred language and not the browser. Sometimes I work at another location where I cannot change the browser setting.

I want to change from Portuguese to English. I already try to change the configuration but it doesnt work. The website layout is still in Portuguese

Finally solved ... -_-

Is there a url I can access to change the language ? 

id.atlassian.com is showing up in a weird language even though the one selected in my browser is English.

 

Please provide a url to change the language to english.

I have this issue too, even if it is said to be fixed, my default language is set to english, but still all the ui is in polish

0 votes

As a JIRA Administrator, you can change the default language by clicking the "Edit settings" button on that same page in the screenshot (General Configuration).

See Choosing a default language for instructions.

How do i change the language please still cant find it

because i cant read it

System Administration/Jira (in left panel)/ in right top corner there is Edit settings

This setting has no effect. Everything is set to "English", yet Jira is in FInnish and I can't find anything. 

Like # people like this

Hi i have something similar.... i have  mixed languages .... could you help me how to solve it. All my computer is in english, the only thing is that the  time is set in spain... here is an image showing the problem

https://imgur.com/a/bXYQwDJ

@Dorthe-Maj Jacobsen if u r using Chrome, on advance settings put  english on the top of the list, this fixed my issue...

cheers

Didn't fix mine - Still shown in Danish (and the translation is horrible).

Like volg memaar likes this
0 votes

I found this which look like the same issue:

"have you changed your language preferences in your user profile?

This language setting should be the first one to take effect."

From: https://community.atlassian.com/t5/Confluence-questions/Confluence-language-displays-in-Swedish-no-matter-what-language/qaq-p/1101811

I spent 1 hour to fix it, and even submitted a ticket. It was just a matter of changing my PERSONAL language.


I'm also having this issue. Language settings are an absolute mess. 

  • When Jira first loads, it's shown in English. Then in a few milliseconds, it switches to Portuguese.
  • My Jira default language (under System > ...) is set to English.
  • My browser (Chrome) uses English as its default language.
  • My Jira profile is shown in English.
  • My Jira profile default language is set to English.
  • Confluence was being shown in Portuguese, with a lot of random English stuff. It decided to choose Portuguese as its default language for me. Unlike Jira, changing its default language to English actually did the trick.

I have no idea where Jira gets its language config from. It just decided it's going to be Portuguese and that's it.

Choosing your display language shouldn't be that hard.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

Demo Den Ep. 7: New Jira Cloud Reports

Learn how to use two new reports for next-gen projects in Jira Cloud:  Cumulative flow diagram and Sprint burndown chart. Ivan Teong, Product Manager, Jira Software, demos the Cumulative ...

375 views 1 3
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you